User import and export plugin for openfire 3.9.3


I need old user import and export plugin that compatible with openfire 3.9.3.

Because my carelessness, I have updated the plugin with the latest version which is not compatible with openfire 3.9.3.

Now everytime I open user export, the page blank. (See attachment picture for more detail)

Please anyone can help ?

Thank you very much

The plugins available here may work for you


Daryl, your link points to 2015.12.02 binaries. This is not for 3.9.3.

This one is.
userimportexport.jar (287298 Bytes)

hmmm… where is the link to download the correct plugin?

thank you


I have tried it, but after I installed, the page for user import and export just show not completed.

Please see attachment for more detail.

I’ve just tried the one i attached (2.4.0) on a clean Openfire 3.9.3 installation and it works. Maybe you haven’t deleted the one you hae installed (2.5.0) from Openfire/plugins (both the jar and the folder of it).

P.S. i wonder why Openfire 3.9.3 suggests to update plugins to not supported versions. Isn’t there a version check, Daryl?


I just tried with your suggestion, install clean openfire 3.9.3 then install plugin userimportexport (using your attachment file), the plugin didn’t show up.

I tried install plugin from Daryl attachment, it show but not complete.

Still searching for the correct plugin.

Well, it works for me and it is the only correct version (i have saved it before moving to 3.10.3 version), i should have 3.8.2 version, so i can attach it later. But something is still wrong on your side. Did you install clean version into separate folder or into the same where Openfire already was? Have you deleted old Openfire folder before installing? You can try on a different machine also.

wroot, 3.9.3 has a bug with how it checks versions.

I created a bamboo plugins plan for 3.9 branch of Openfire


Daryl, this plugin in your link is 650 Kb, yet the one I have downloaded before is 278 Kb. Wonder why there is such difference. I haven’t tried it from your link though.

Daryl’s variant works too, though as i said it is 3 times larger in size. Here’s 2.3.1 version which was provided with Openfire 3.8.2. Works for me too.
userimportexport.jar (287167 Bytes)

I dunno why, but it still not working.

Well, the last action I took are manually input user and group in openfire 4.0.1

Thank you very much for all your help guys

Too bad openfire 3.9.3 cannot identify the correct plugin.

Anyway, thank you very much for all your help.

Last action I do, just input manually for user and group