powered by Jive Software

User Import & Export failing on usernames with spaces in them

How do I use the import plugin to import users that have spaces in there usernames? When I add them through the admin web interface they are added fine.

don’t use invalid characters in the names when you create them… strictly alpha numeric characters no spaces or other such junk.

Hi,

http://xmpp.org/extensions/xep-0106.html#unescaping may help.

Would you please post a sample user name here. Do you use the import/export plugin?

LG

XMPP supports UTF-8 (without A-Z) so one can likely never use “junk”.

Thanks that (http://xmpp.org/extensions/xep-0106.html#unescaping) is exactly what I was looking for. I am using the import/export plugin and when I substitute the spaces (\20) and single quotes (\27) then the import works. :smiley: Thanks

Gee I am so glad we propagate the use of invalid characters. UTF-8 may support the characters but that does not mean they are supported by routing protocols or other such aspects of a web enabled applications. Just because you can use a character does not mean you should.

again for those who do not understand. spaces apostrophes and other non-alphanumeric characters should not be used for web based protocols. you would not make a web address www.ignite realtime.com would you. same reason you do not use it in a username that is used as part of the server discovery and authentication protocol. Just because the time was not taken to code an exclusion error for people trying it does not make it right to use them. Same goes for LDAP, email and other such protocols. You can use any character you want but it does not mean it will work. Yes you can use the escape code characters which serve to cover ones butt for using invalid characters.