powered by Jive Software

User remains in spark after deletion

I have removed certain users from spark as they have left the company but for some reason my cache for spark still showes the users in the list i have removed them from the spark security group and removed them from active directory i also have restarted openfire server and it does not show the users in the of groups that are pulled in from ad but does show them in my spark any ideas on how to clear this error.

Thanks

Hi,

I am experiencing exactly the same problem. We are using Openfire 3.6.4 with Active Directory, MySQL and Spark 2.5.8.

I created a test user in AD, added to a contact list, logged in as the user and accepted my user request all works fine. I then deleted the user from AD, cleared all caches on the Openfire server and restarted Openfire.

On the PC I de-installed the Spark client and ensured that the spark directory in program files and my Documents and Settings directory had been deleted. I re-installed Spark, logged back in and the deleted user still shows in Offline contacts.

I am unable to search for the user (as expected)

I am unable to move the user from the Offline group into a new group.

If I view the profile of the user I just see the JID

If I look at the MySQL database there is an entry for the user and for me in the ofRoster table there is also an entry for the user in ofPresence.

Is there any way of rectifying this situation as it may stop me deploying Openfire/Spark into our environment?

Regards,

Doug

I was just searching for a solution to this issue and ran accross this post. This is an old thread, but I wanted to post the fix in case anyone else is searching.

We are using Openfire 3.7.1 AD integrated with Spark IM client 2.6.3.

After removing a user from all groups associated with SPARK in AD, user still showed up in Spark client as offline user.

FIX Accessed openfire console as administrator. Go to SERVER>SERVER MANAGER>CACHE SUMMARY. Find Offline Presence Cache - place check in box, scroll to bottom and select “Clear Selected”. Restart Spark client - user no longer shows up.

2 Likes

I tried this and it didn’t work. I also tried clearing the user cache, also not helpful.

Spark 2.6.3

Openfire 3.9.1

This just worked for me to get a user out of a group that they were no longer in according to AD.

I still have users show as offline that are not in any groups. Any idea what cache I can try clearing to fix this?

Is there a doc that explains what the functions of the various caches are?