powered by Jive Software

User Service Plugin

Hi,

I’ve installed the User Service plugin, which is exactly what I need, in our openfire server.

I ran the following from a web browser to test it:

http://server:9090/plugins/userService/userservice?type=‘add’&secret=‘bigsecret’ &username=‘test’&password='test123

When the plugin is disabled I get the expected: UserServiceDisabled

When it is enabled and the secret is configured, I get: RequestNotAuthorised

Can anyone help?

By the way, when trying to run the URL without the ‘’ around the values I get an error in the browser.

For what it is worth, did you change your secret and make sure it matches in your request?

From the docs:

RequestNotAuthorised

The supplied secret does not match the secret specified in the Admin Console or the requester is not a valid IP address.

I am unsure of what would define a valid IP address, if your secret matches, I would look into that.

I would be curious of your results as we have used this plugin without any problems for some time now.

Yes, I did.

I found the problem, but I have no idea how to fix it.

I should use the URL without the ‘’ around the values.

When I use this URL:

http://192.168.4.35:9090/plugins/userService/userservice?type=add&username=test& password=test123&secret=bigsecret

I get an error:

HTTP ERROR: 500

gnu/inet/encoding/Stringprep

RequestURI=/plugins/userService/userservice

Caused by:

java.lang.NoClassDefFoundError: gnu/inet/encoding/Stringprep     at org.jivesoftware.openfire.plugin.userService.UserServiceServlet.doGet(UserServiceServlet.java:130)

It is a lot longer than that, but I didn’t want to copy it all.

I only added the ‘’ to the secret’s value and the error is gone, but now the secret is not the same one I configured… This is why I get RequestNotAuthorised.

Actually, I tried a few more changes - my conclusion is that only when all the parameters has the RIGHT values I get this error… Any suggestions?

I got an answer from R2D2 in another discussion that solved the problem:

“I solved the problem by downloading the source for user service, downloading the gnu stringprep source code, and then compile both together to create a new binary.”

The only pblm is secret key is mismatched. check ur secret key go to Server Settings ->User Service -> select the Secret key text and use it.