powered by Jive Software

Users Getting Disconnected

I am having a problem where users are constantly getting disconnected. Sometimes it effects only one or two users and sometimes all users get disconnected at the same time. I’m using a fresh install of OpenFire linked to Active Directory. I am running OpenFire on a virtual server with a Xeon 3.06Ghz, 2GB RAM, 5GB HDD with 2.41GB free, and a WinServ2003 OS. This is the same virtual server that had OpenFire 3.5.2 running on it for well over a year, maybe two with no problems at all. I have tried using the default port and port 3268 per another discussion’s recommendation. I am using the Spark client and have also tried adjusting the Response Timeout setting in Spark from 10sec to 30sec and then to 60sec. So far there has been no change in results. I have attached the log file from the last time we were disconnected in hopes that it may help.

2009.01.28 12:24:57 [org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroup(LdapGroupProvider.ja va:91)]

org.jivesoftware.openfire.group.GroupNotFoundException: Groupname SparkUsers not found

at org.jivesoftware.openfire.ldap.LdapManager.findGroupDN(LdapManager.java:855)

at org.jivesoftware.openfire.ldap.LdapManager.findGroupDN(LdapManager.java:782)

at org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroup(LdapGroupProvider.jav a:83)

at org.jivesoftware.openfire.group.GroupManager.getGroup(GroupManager.java:278)

at org.jivesoftware.openfire.group.GroupManager.getGroup(GroupManager.java:257)

at org.jivesoftware.openfire.group.GroupCollection$UserIterator.getNextElement(Gro upCollection.java:103)

at org.jivesoftware.openfire.group.GroupCollection$UserIterator.hasNext(GroupColle ction.java:66)

at org.jivesoftware.openfire.roster.RosterManager.getSharedGroups(RosterManager.ja va:162)

at org.jivesoftware.openfire.handler.IQSharedGroupHandler.handleIQ(IQSharedGroupHa ndler.java:44)

at org.jivesoftware.openfire.handler.IQHandler.process(IQHandler.java:49)

at org.jivesoftware.openfire.IQRouter.handle(IQRouter.java:351)

at org.jivesoftware.openfire.IQRouter.route(IQRouter.java:101)

at org.jivesoftware.openfire.spi.PacketRouterImpl.route(PacketRouterImpl.java:68)

at org.jivesoftware.openfire.net.StanzaHandler.processIQ(StanzaHandler.java:319)

at org.jivesoftware.openfire.net.ClientStanzaHandler.processIQ(ClientStanzaHandler .java:79)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:284)

at org.jivesoftware.openfire.net.StanzaHandler.process(StanzaHandler.java:176)

at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(ConnectionHandl er.java:133)

2009.01.28 12:47:00 JettyLog: EXCEPTION
java.io.IOException: An existing connection was forcibly closed by the remote host
at sun.nio.ch.SocketDispatcher.read0(Native Method)
at sun.nio.ch.SocketDispatcher.read(Unknown Source)
at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
at sun.nio.ch.IOUtil.read(Unknown Source)
at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
at org.mortbay.io.nio.ChannelEndPoint.fill(ChannelEndPoint.java:122)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:282)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)
2009.01.28 12:47:00 JettyLog: EOF

I notice on line 2 that it states that “Groupname SparkUsers not found”. SparkUsers was our AD test group and had been removed from both AD and OpenFire before we launched the server for the users. This may have nothing to do with the problem or it may be the problem. I’m really not sure.

Thank you,

Jason

I thought the problem may have been the Spark client. I have now also tried using Pidgin with the same results. Before when the server was running fine it was not linked to our Active Directory system. Could there possibly be a problem between the OpenFire server and the AD servers? Will OpenFire disconnect clients if it does not get a timely response from the AD system?

I have attached a pic of the server traffic log from OpenFire. It seems that everytime we get the large blue spike is when users get disconnected.

i have the same problem but a i use the system of openfire for create users…

if i have a solution i tell you.

I noticed you had posted in my thread. Seems we have a similar issue. Neither of my installs have been tied to AD. I’ve tried many clients all with the same result. I can’t for the life of me figure it out. I’ve tried finding info on potential settings in the server to change, but I’ve yet to find a solution. The disconnects are also very short and within 10 seconds the user is reconnected. If I do find one I’ll let you know.