powered by Jive Software

Using Fastpath without WebClient

We are deploying Openfire (3.6.0a) and Spark to all the users on our internal network. We want to use the Fastpath plugin for IT Help Desk stuff. But all of our users are going to be using the Spark client (v2.5.8), and I can’t seem to make it work. I have created a workgroup and when I log in it shows the Fastpath tab in Spark. So the agent stuff if working fine. But how do I send requests to the workgroup from another Spark client, not the webUI??

You should add a workgroup to your rosters. As far as i remember i was able to add a workgroup to a shared group. You have to specify a JID (e.g. demo@workgroup.server). Then you’ll be able to “chat” with a such contact in Spark.

That worked. Thanks for the info, I had tried adding it to the roster, but had not tried using the full JID.

Is there a way that I can chose which options are necessary to start a chat? Right now it wants Name, Email, Question. All I really need is Name.

Well. You can try to remove those questions in Fastpath Settings. Forms section or UI. But it still lacks flexibility.

I found it now.

It’s just for one of the Workgroups, the others will still use the fully featured options.

Thanks for the help.

Not sure if I understand the difference between a workgroup and a shared group. I can see the Workgroup settings under the Fastpath Admin page. But how do I add the Workgroup I created to a shared group?

I’m having the same problem where I don’t need to use Webclient, just need to use it internally.

Would appreciate some help with this.

Thanks.

allstatesmed wrote:

But how do I add the Workgroup I created to a shared group?

As i’ve said in 2nd posting here, you have to add such workgroup to your shared group using its full JID. Normally you add users to a shared group specifying only their usernames. In the fastpath case you should put workgroup_name@workgroup.server_name in the Add user field. It will show some error, but it will add such a user.

Ok, I believe I added the workgroup according to your suggestions. When I look at the Spark chat tool, I can only view each individual user account. Even under the Fastpath tab I don’t see any online agents or preferably, a queue to send messages to.

Not sure where it’s going wrong.

You should try to relogin in Spark. Also, you may want to enable offline users showing or check the Offline group. And one of that workgroup agents should be online for it to be online too. Once again, after one of the workgroup agents goes online, this workgroup account in your roster won’t immediately change its status to online. Most probably you would have to relogin to see it online.