powered by Jive Software

Using shared groups, not receiving online notification

Hi!

Im using openfire 3.6.4 and smack 3.1.0 and having problems using the ‘shared groups’ functionality in openfire admin console. Creating users, creating groups and adding users to groups thru admin console went smoothly. I can even login to openfire using those newly created users. Iterating thru the rosters of each user shows exactly what is configured in the admin console, and roster.getPresence() also returns the right status snapshots and subscription is ‘both’. The problem is, every time another user logs in, nothing is received. Ive setup my roster listener as stated in the docs:

roster = xmppc.getRoster();
roster.setSubscriptionMode(Roster.SubscriptionMode.accept_all);
roster.addRosterListener(new RosterListener() {
     public void entriesAdded(Collection<String> addresses) {}
     public void entriesDeleted(Collection<String> addresses) {}
     public void entriesUpdated(Collection<String> addresses) {}
     public void presenceChanged(Presence presence) {
          processPresence(presence);
     }
});

presenceChanged() is not firing after a user successfully logs in. The interesting part is that it gets fired if a user logs out. I even tried this code:

PacketListener listener = new PacketListener() {      public void processPacket(Packet packet) {
          Presence presence = (Presence) packet;
          processPresence(presence);
     }
}; PacketFilter filter = null; filter = new AndFilter(new PacketTypeFilter(Presence.class), new ToContainsFilter(username));
xmppc.addPacketListener(listener, filter);

Yet same thing happens. I tried unsharing the group, login in 2 users (user1 and user2) of the same group and then re-share the group. Guess what, the 2 users received unsubscribe packets with a corresponding unavailable packets and im wondering why.

2 users (user1 and user2) currently logged in, and their group currently shared, i tried logging in another user (user3) who’s also a member of the shared group USING Spark Client (not my app). Everything’s fine with spark, even after unshare/reshare of group. So i guess im missing something.

The last thing i tried is manual subscription, still no luck.

Can anyone please help…

Thanks,

Rolando