powered by Jive Software

UTF8 to UTF8mb4 for Offline Messages

Hi,

i am experiencing a issue where i can’t send custom emojis, when the reciepent is offline. If both parties are online it works without any problems.

So i thought it must be to do something with the MySQL DB when are message gets stored as a offline Message. I executed the following MySQL Statements:

ALTER DATABASE openfireDB CHARACTER SET = utf8mb4 COLLATE = utf8mb4_unicode_ci;

ALTER TABLE ofOffline CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

ALTER TABLE ofOffline CHANGE stanza stanza text(1024) CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

ALTER TABLE ofMessageArchive CONVERT TO CHARACTER SET utf8mb4 COLLATE utf8mb4_unicode_ci;

It worked for a short time, but now it doesn’t anymore. My DB didn’t forget those executed statements( i have checked the tables and they are still in utf8mb4)

Thanks,

django

I see that you have applied Wael’s suggested changes from OF-695. Don’t know why it stopped working, but i have added you observations as a comment.

Yes, i have followed those instructions. I will take a closer look at this problem within the next days and report feedback.

Hello wroot,

i have investigated this issue. The commands above are working fine and are definitely the way to go. In my case the issue was that i had a Option-Group for my MySQL server wich was overwritten every time a reboot or maintainence happens. Defined a permanent Option group for my db (character_set_filesystem, character_set_client, character_set_connection,character_set_database, character_set_results, character_set_server -> all to utf8mb4) and (collation_connection, collation_server -> all to utf8mb4_unicode_ci) everything works. The tables were utf8mb4 as described above but without the option group settings it couldn’t work.

Sorry for confusing