powered by Jive Software

vCard info not pulling over from AD server into OF 3.6.4

I think I’m having a pretty standard issue, as I’ve seen many posts regarding it, but I have yet to find a solution. I am running an Openfire 3.6.4 server with Spark IM for client PCs. I am authenticating to an Active Directory using LDAP settings and that part is working. My user group is populating with all of the proper users, but on user’s contact lists, there is no other visible information on other users besides their name. So I imagine this is a vCard issue, and yes, I’m not very familiar with vCards. I assume they pull the information that’s in the fields in a user’s Active Directory account properties window. Here is what I have pasted in my openfire console under Server > Server Manager > System Properties > ldap.vcard-mapping:

{sn}{givenName}{mail}{displayName}{dis playName}image/jpeg{jpegPhoto}</ PHOTO>{homePostalAddress} {postOfficeBox}{l}{st}{pos t alCode}{c}{homePhone}</N UMBER>{telephoneNumber}{mobile}{pager}</N UMBER>{facsimileTelephoneNumber}< T ITLE>{title}{wWWHomePage}{company}{department}

I have no idea why this isn’t working. Like I said, my newbness when it comes to vcard stuff is quite unprecendented. But I’m pretty knowledgable about everything else, so if someone could at least point me in the right direction (since the other posts regarding vcards haven’t worked), I would be ecsatic!

If someone needs more info, just lemme know!

Chris

My settings are working, for the same setup. These were the installer’s defaults, but they look different from what you have. I’m also attaching a screen shot.

If that doesn’t work, maybe it’s a permissions problem with the AD user Openfire is using for authentication. You could test it with an administrator account, for example, and see if you have the same problem.

{cn}



{mail}

{displayName}


{homePostalAddress}
{homeZip}
{co}



{streetAddress}
{l}
{st}
{postalCode}
{co}




{homePhone}




{mobile}




{telephoneNumber}




{mobile}




{facsimileTelephoneNumber}




{pager}

{title} {department} ]]>"><![CDATA[ {cn} {mail} {displayName} {homePostalAddress} {homeZip} {co} {streetAddress} {l} {st} {postalCode} {co} {homePhone} {mobile} {telephoneNumber} {mobile} {facsimileTelephoneNumber} {pager} {title} {department} ]]>

please attach a screenshot of what you are seeing…

I’m trying to copy/paste your vcard-mapping into the field in my System Properties page in the console, but it keeps getting jacked up. I’ll clear out my mapping, paste yours in, verify that all the extra line breaks and spaces are deleted before clicking save, but after I save it, it still doesn’t look right. Is there any way to add the vcard mapping into a config file so it pulls it from there rather than the console? Or maybe I’m using the wrong browser? Downloading IE8 as I write this…

This could very well be my problem though. When I first could not get vcard info to map over, I assumed it was a problem with the mapping syntax, so I started changing it based on other forums I’ve seen. What I SHOULD have checked first was the AD account that Openfire uses to authenticate with, which is an LDAP Auth Account I created, but I don’t believe it had the proper permissions. After I jacked up the mapping beyond the point of recognition, I threw the LDAP Auth Account into the domain admins group. But now I can’t seem to get my mapping field back to the install default, as you have given me.

http://www.igniterealtime.org/community/docs/DOC-1773

Ok I have done this, still no change. I’m wondering if it has anything to do with the fact that I’m currently running Openfire on an XP Pro machine that we were going to junk, but decided to prototype a chat server. But I can still authenticate to AD with LDAP, so I would think that it being on XP Pro wouldn’t matter, since LDAP doesnt care, it just cares about credentials.

I’m still trying to think of ways to get vcard info to pull over. I’ve checked everything that I can think of.

As requested:

what about when you click view full profile. are you sure all the information is in AD.

Openfire does not care that it is XP.

I don’t see where to view “full” profile, but I do see “view profile”. That part is included in the last screenshot I sent. And I’ve verified that most of, if not all, fields are filled in the user’s AD fields. But when I choose View Profile in spark, nothing comes across except the users full name. So I’m guessing that it’s reading the full name from the AD object itself, and not vcard. Doesn’t seem like vcard is pulling over at all. And it shouldn’t be an authentication issue since my LDAP Auth Account is in Domain Admins group. <hmph!>

Thanks sixth for your continued help…

in your pic is the view full profile button.

Oh snap! Didn’t even see it. Now **there **is the vcard stuff. So the only thing that’s not showing, is when I mouse over a contact. The only thing that’s showing is jabber ID. So does that mean that “View Profile” displays jabber profile information, and “View Full Profile” displays vcard info?

Thanks! At least I know that vcard is working now!

Is there any way that the jabber ID can pull info from vcard? Or is my thinking off-base?

that could be a bug. I am not sure how that works. I would ask ctux or some others in open chat on wednesdays.

Hmm. So when I look at the Full Profile and see all the vcard stuff, I should be seeing some of that information when I mouse-over a contact? Or when I choose to view their jabber profile? I’ll see if I can free myself up for that chat on Wednesday.

Thanks!!