powered by Jive Software

Video between clients not working

Running OpenFire 4.1.5, ofmeet 0.9.2, and focus 0.9.2. Server is Windows Server 2012 R2.
Background. This setup did not work. Got the dreaded Oops error when trying to create a room at https://my_domain:7443/ofmeet. Once I removed focus and ofmeet and loaded their previous version it started working. I then upgraded to 0.9.2 on both plugins and it continued to work. For focus I am running AD intergration so I created a focus user and focus is working. 2 clients can connect to the same room and chat, but no video. Right now I am only concerned about getting it to work locally so nat issues right now. Firewall is off. Not sure if there is a step by step documentation for this simple setup. New to this so any direction would be helpful. Tried 3 different browsers and all access the camera fine as each client can see their own video. Just can’t see each others. Had each client go to https://meet.jit.si and they were able to see each other. So I don’t think its a browser issue. Do I need to enable Media Proxy? I have enabled it but still nothing. Looking at the room I see the clients and the focus user. Just no dang Video.

I noticed ( today ) that is not possible to send video via ofmeet web app. Only audio manage to be sent…
Is your issue and mine a result of Chrome M61 update of yesterday ?
In the patch notes there is a change in the audio stream not "waiting " for the video stream . Link below .
https://groups.google.com/forum/#!topic/discuss-webrtc/8gJyg8EFPdo

If this is true then how could this be overcome ? code wise im asking

As context im using Openfire v4.1.3 , Ofmeet 0.9.2 .
Only this combination was in working status for me for several months As of today is not …

Openfire 4.1.5 is bugged out when combined with websocket plugin and ofmeet plugin, from what i saw.

Still using Chrome 60. What about other browsers though? I might dump 4.1.5 and try 4.1.3 then. Still in testing phase.

Installed 4.1.3 but ofmeet and focus are not listed in the plugins. Did you just download them and upload them in?

Tried manually to upload focus .9.1 but even though it uploaded its not listed.

Well I tried 4.1.3, then wiped it, saw someone else post about using openfire 3.10 and ofmeeting 1.4. Neither worked. Think I am about ready to just give up. These plugins just don’t seem to work as advertised. At least on Windows, the video does not function correctly. Would like to see the directions for any platform that actually works. Really wanted this Video/Chat to function.