powered by Jive Software

Video conferincing

Does the current version of Openfire support video conferencing? I’ve tried the jitsi plugin, and Red5 and cannot get either to work. So I was wondering if anyone had any similar issues or is this a feature that has been dropped?

Sure it does work. All you need is to install and set up the required openfire plugin aswell as the redfire plugin for spark. As server plugin use this file.

I wrote a how-to for end users downloading and configuration the client plugin. You can find it here Red5-Plugin How-To & Download - it’s written in german language but you can use google translator.

Hope that helps.

1 Like

Dear Rene,

I have followed your instructions closely but am still having an issue.

Even though I configured the red5.properties for my server settings, when I click the Red5
button in Spark, the receiving Spark client receives the following message:

This page can’t be displayed

Make sure the web address http://mydomain.local:7070 is correct

My red5.properties file’s contents are:

#Red5 Settings

server=192.168.1.20 (this is my Openfire server’s IP address)

port=7070

popup=false

protocol=http://

I am able to get to the http://192.168.1.20:7070/redfire/ page.
The Publisher/viewer application works fine but NOT the 2Way audio/video.
I get a grey screen that only says “Enter…Connected” at the bottom but no video.

Please help since I have spent a lot of time trying to make this work.

Thanks,

Tim

Dear Dele,

Thank you for replying to my issue.

However, I wasn’t able to read your reply.

Thanks,

Tim

Can you attache a screenshot of the screen saying “Enter…Connected”? Does it opens within a webbrowser? Look closely unter the URL bar - there might be a notification, that the webbrwoser wants to use your audio/video device. You must accept this to get a stream.

Rene, I am not able to upload the image “Enter_Connected.png” to this forum.

Unauthorized

You don’t have permission to do the requested action. You might need to log in to the system before you can continue.

It appears you’re not allowed to view what you requested. You might contact your administrator if you think this is a mistake.

However, it simply says “Enter…Connected” on the bottom of the screen at the URL:

http://192.168.1.20:7070/redfire/video/redfire_2way.html?me=test1&you=test2&key= secret_key

I do not see my own video even though my web camera is connected.

Dele / Rene, could it be that the Redfire (Red5) Spark plugin is getting the settings from my Openfire installation since I connected Openfire into Active Directory?

No matter what settings I enter into the red5.properties file, it still sends the Spark user to:

http://mydomain.local:7070 instead of http://192.168.1.20:7070 .

Please help.

Thanks ahead of time.

IP address will not work with Redfire. It is mentioned somewhere here a few times that you need a DNS entry for your openfire server domain name pointing at the openfire server.

Also find the log files for red5 plugin for Spark. It will confirm if it has found the red5.properties file.

1 Like

Dele,

Thank you for your reply.

I have modified the red5.properties file (as you instructed) in my C:\Users\username\AppData\Roaming\Spark\plugins\redfire-plugin

folder:

#Red5 Settings

server=openfireserver.domain.local (Note: this was changed from just entering the IP of 192.168.1.20)

port=7070

popup=false

protocol=http://

All Spark clients and our Openfire server are in the same LAN so there is no need to modify WAN settings.

If I ping this DNS address interally, it responds with my server’s IP: 192.168.1.20
Also I logged off of Spark and back in again.

However, when I click the Red5 button, it still displays domain.local:7070 .
My Spark freezes on the following error (and I must forefully close Spark):

This page can’t be displayed

  • Make sure the web address http://domain.local:7070 is correct.
  • Look for the page with your search engine.
  • Refresh the page in a few minutes.

Could I be modifying the file in the wrong location ?

I would love to get this working finally since I would like to help others with the similar problem but I am not sure why changing the red5.properties file doesn’t make any change.

The file location depends on which version of Spark and OS. To find it, first locate the log files for Spark and view them. You should see a message confirming if the file was found or an error indicatiing where it expects it to be

Also make sure you can ping the domain name from a comand prompt and it returns the correct IP address

Dele,

I am able to ping the DNS successfully.
My OS is Windows 7 Pro 64bit and I am running the latest version of Spark (2.6.3).
My version of Adobe Flash is 11,9,900,170 (the latest version is installed on both pcs).

Sorry, it is not here. Try the others (warn.log, etc)

Dele,

According to my Spark error.log located in C:\Program Files (x86)\Spark\logs,
my red5.properties file is stored in the following location: C:\Users\myusername\Spark

The file only contained “protocol=http://” !

Thank you greatly for your help !

on my pc

C:\Program Files\Spark\logs

error.log

output.log

C:\Users\XXXXXX\AppData\Roaming\Spark\logs

errors.log

warn.log

Dele,

Spark is now sending the correct link.

However, I still have the issue that no video is being displayed.

The only message I see is “Enter…Connected” on the bottom of a blank screen on both pcs.