powered by Jive Software

Video not visible in ofmeet

I managed to make jitsi videobridge work on my intranet. However when I host this on my internet facing server and access it from a remote desktop, I do not see the video.

It prompts for authentication, I enter the userid and pass word. Post this, it opens the video chat page but no video is visible. Even the chat window does not show any messages

When I debug it in browser chrome, below is the log that I get

This appears to be Chrome main.js:367

status 1 main.js:138

SEND: main.js:112

RECV: stream:featuresDIGEST-MD5PLAINCRAM-MD5zlib</stream:features> main.js:111

status 2 main.js:138

status 7 main.js:138

SEND: main.js:112

RECV: main.js:111

status 6 main.js:138

The openfire version is 3.9.3 on Windows 64 bit

try this

My server is not NATed.The public IP and local IP are also the same. I have still added the properties menitoned above but still there is a problem. Once I try to initiate a webrtc session, it asks for authentication. Once authenticated, the video doesnot come up. If I click chat, it asks for nick name. Even after entering the nickname, the chat doesnot start.If I view the sessions on the sevrer, they do not show up the client sessions.

We have tried this and After adding the Above method It was not Sucessfull so after removing the above I have Got this error in My server Log file

Error Log

2014.05.15 12:28:46 org.jivesoftware.openfire.spi.ConnectionManagerImpl - Could not setup a server socket

java.net.BindException: Address already in use: bind

at sun.nio.ch.Net.bind0(Native Method)

at sun.nio.ch.Net.bind(Unknown Source)

at sun.nio.ch.Net.bind(Unknown Source)

at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)

at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)

at org.apache.mina.transport.socket.nio.SocketAcceptor.registerNew(SocketAcceptor. java:363)

at org.apache.mina.transport.socket.nio.SocketAcceptor.access$800(SocketAcceptor.j ava:55)

at org.apache.mina.transport.socket.nio.SocketAcceptor$Worker.run(SocketAcceptor.j ava:222)

at org.apache.mina.util.NamePreservingRunnable.run(NamePreservingRunnable.java:51)

at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Hi,

Some more things that I tried here

a. Checked the netstat on the server and noticed that the client request are received on the video chat port 7443. But the video is not received and port gets closed… Is there any other way to debug/trouble shoot this.

Attached the output of netstat

180.149.245.130:5222 203.188.224.59:29420 ESTABLISHED

TCP 180.149.245.130:5222 203.188.224.59:64279 ESTABLISHED

TCP 180.149.245.130:5222 203.188.224.59:64563 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15957 CLOSE_WAIT

TCP 180.149.245.130:7443 203.188.224.59:15958 CLOSE_WAIT

TCP 180.149.245.130:7443 203.188.224.59:15959 CLOSE_WAIT

TCP 180.149.245.130:7443 203.188.224.59:15966 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15967 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15968 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15969 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15970 ESTABLISHED

TCP 180.149.245.130:7443 203.188.224.59:15971 ESTABLISHED

TCP 180.149.245.130:8080 RX4510:0 LISTENING

TCP 180.149.245.130:8096 115:54221 ESTABLISHED

TCP 180.149.245.130:8096 ABTS-North-Dynamic-106:50868 ESTABLISHED

TCP 180.149.245.130:51100 pi:5222 ESTABLISHED

TCP 180.149.245.130:55036 pi:ms-sql-s ESTABLISHED

TCP 180.149.245.130:60749 pi:ms-sql-s ESTABLISHED

TCP 180.149.245.130:62635 pi:ms-sql-s ESTABLISHED

TCP 180.149.245.130:62639 pi:ms-sql-s ESTABLISHED

TCP 180.149.245.130:63057 pi:ms-sql-s ESTABLISHED

TCP 180.149.245.130:63075 pi:ms-sql-s ESTABLISHED

Hi,

We tried to debug the main.js files and log shows that the connection is ATTACHED but there doesnot seem to be any media exchange. Is this a bug or some configuration issue. Attached is the strophe main.js console log

This appears to be Chrome main.js:399

UseWebsocketfalse main.js:105

boschhttps://180.149.245.130:7443/http-bind/ main.js:106

jid180.149.245.130 main.js:128

status 1 main.js:152

status CONNECTING main.js:160

status ATTACHED main.js:168

SEND: main.js:124

RECV: stream:featuresDIGEST-MD5PLAINCRAM-MD5zlib</stream:features> main.js:123

status 2 main.js:152

status CONNFAIL main.js:162

status ATTACHED main.js:168

status 7 main.js:152

status ATTACHED main.js:168

SEND: main.js:124

RECV: main.js:123

status 6 main.js:152

disconnected main.js:156

status ATTACHED