Voice chat problem


Firstly, I’m not much up on network chat or the protocols used to carry the chat - please bear this in mind should you answer this post. I’m trying to get voice chat to work on a small intranet. At the moment I have Openfire on one machine and Spark on two clients. All machines are running XP SP2. The program seems to work fine for text chat, but I can’t get the voice chat to work. When I try to place a call from one machine to the other, the receiving client notes the call. I click on accept and it tries to setup the call but then I get a message ‘Voice Chat Ended. No media received. This may be due to firewall configuration’.

The only firewall on the machines is Windows firewall. I disabled this on both clients and the server but it didn’t make any difference. I disabled my anti-virus and changed my intranet security settings to low, but no joy. I even disabled the firewall on the router but it didn’t work. This is about as far as my limited experience can take me, and I’m at a loss for what to do next. Should I have something else installed on the machines to enable voice chat? I’ve looked through the Openfire admin panel but I can’t find anything that might allow voice chat. Do I need a plugin or something.

It looks like a great progam and I’d like to use it but I really need voice chat. Please help!! :_|


We are experiencing the same issue (same tests and environments as described below). It does not seem to be a firewall nor an OS issue (Calls with Coccinella work fine).

Most of our 1000 users will be just fine with text chat but we really need voice calls for some of them. Any help would be greatly appreciated.

Thank you.

I’m having the same problem :S

nothing is blocked on the 2 client machines / server / cisco switch

Can’t see UDP packets with wireshark

the problem is intermitent because voice calls work in the morning.

It worked when I came in to work this morning, two hours later it’s dead.

I spoke with the admin in charge of our network and the admin in charge of his network, still no clue as to what is happening, even with everything open with allow any any.

The calls used to work no problem a few weeks ago.

Seeing similar things myself - everything seems to be configured correctly but no matter what version of the Spark client I install, the voice chat isn’t available.

The Openfire server is running under Ubuntu 8.04 using the Debian package and installed fine but the Win Spark clients (have tried both msi/exe jre/nojre) don’t have voice chat capabilities (all XP SP2).

I’m wondering if the others with a similar issue can confirm their server setup/ clients used?

i have the same configuration , can you solve it?