powered by Jive Software

Vps and jvm

To whom might interest I´am running wilfire 3.1.1 on a vps with 768 memory barrier with cpanel.

It uses java 1.5.02…the minute I instaled version 1.6.02…I´ve got these in my error.log after the 5th user tried to login…

2007.09.05 18:03:22 org.jivesoftware.wildfire.net.SSLSocketAcceptThread.run(SSLSocketAcceptThread.ja va:181) Could not setup SSL socket

java.lang.OutOfMemoryError: unable to create new native thread

at java.lang.Thread.start0(Native Method)

at java.lang.Thread.start(Unknown Source)

at org.jivesoftware.wildfire.net.SSLSocketAcceptThread.run(SSLSocketAcceptThread.j ava:153)

I´ve tried all the vm options that I could tell and read this also http://www.igniterealtime.org/community/docs/DOC-1033

Eventually I´ve tried with INSTALL4J_ADD_VM_PARAMS="-Xms16m -Xmx128m -Xss256k -Xoss256k -XX:MaxPermSize=32M -XX:PermSize=32M -XX:ThreadStackSize=128 -Djava.net.preferIPv4Stack=true

"

and the problem persisted…

The solution I´ve found ? yeah…revert to java 1.5.02…and now it is working

Don’t know if it´s a java problem or a wildfire problem, since I can´t upgrade to openfire because of a epoll kernell problem…but my problem is related here like my solution…might help anybody…