powered by Jive Software

Want to know the service name of Openfire 4.1.3 server?

Is any body know how to find service name of Openfire 4.1.3, because i need to connect with Openfire 4.1.3 with my android app.

This is my code;

XMPPTCPConnectionConfiguration.XMPPTCPConnectionConfigurationBuilder builder=

XMPPTCPConnectionConfiguration.builder();

builder.setServiceName(“10.0.2.2”);

builder.setUsernameAndPassword(“admin”, “xxxxxxxx”);

builder.setHost(“10.0.2.2”);

builder.setRosterLoadedAtLogin(true);

builder.setResource(“Rooster”);

//Set up the ui thread broadcast message receiver.
setupUiThreadBroadCastMessageReceiver();

mConnection = new XMPPTCPConnection(builder.build());

mConnection.addConnectionListener(this);

mConnection.connect();

Message was edited by: shree

That’s a weird question. You don’t know server’s name/domain that you have setup or want to connect? It is shown on first page in Admin Console.

Remove the password from your post (seems genuine password)

I want to connect openfire server with android. I tried with spark too, it’s showing connection error. If u help me. It’ll b very better to me.

Thank you. I changed it. Can u say how to connect spark with openfire. It’s showing error while i’m connecting.

Show us what you are putting on the Spark login screen (screenshot), what it shows on the Openfire’s Admin Console first page (screenshot) and what error does Spark show (screenshot).

1 Like

You are missing one screenshot that i have asked (Admin Console).

But i already see a problem that you are using IP to login. You have to use server’s domain name, even if you want to login in Spark on the same machine where server is installed.

1 Like

I installed in local machine.

If this is only for testing, then i suggest reinstalling Openfire and use local machine’s name for Domain and FQDN name instead of 127.0.0.1. Spark doesn’t work correctly when using localhost IP. Then in Spark you can use same name as Domain.

1 Like

If i use local machine name as for domain and FQDN name. I cannot able to config the standard Database (MYSQL). That’s why i used it. Can u give any suggestion for it.

No, i have no experience with MySQL. If it is only for testing, you can try using the embedded database, which should work fine on the local machine.

I tried embedded database now, It’s too not working. showing same error.

You have already reinstalled it with embedded databse and using machine’s name as domain name? Was it a clean reinstall with a fresh database? What OS is on your machine?