powered by Jive Software

Webchat not working after update from 4.1.4 to 4.1.5


#1

After update OF v.4.1.4 to 4.1.5 plugin “fastpath webchat” does not working.
http://xxxxxxxx.xx:7070/webchat/
say me:
HTTP ERROR 404
Problem accessing /webchat/. Reason:
Not Found
Powered by Jetty://

After the rollback to the old version (4.1.4) - everything works normally.

In the logs nothing unusual was noticed, but I’m not a pro in Java

If you need any details - please report. I will install the new version again.


#2

What version of the plugin are you using?

Sometimes, when something goes wrong, something is logged to the console output, instead of the regular log files. Depending on what platform you’re running, that output can either be

  • displayed on screen (in a shell where you’re running Openfire)
  • stored in a file (common names are nohup.out and startup.log, but this could be different for you)
  • completely ignored

Can you check if you see anything?


#3

Fastpath Service - 4.4.2
Fastpath Webchat - 4.0.0

Reinstall of webchat plugin have error in log file
All of logs files temporary in xxxxxxxxxxxxxxxxxxxx

warn.log has:
2017.09.25 10:56:55 org.eclipse.jetty.servlet.ServletHandler - /webchat/setup-finished.jsp
java.lang.NullPointerException
<------>at org.jivesoftware.webclient.jsp.setup_002dfinished_jsp._jspService(setup_002dfinished_jsp.java:74)
<------>at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
<------>at javax.servlet.http.HttpServlet.service(HttpServlet.java:790)
<------>at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:812)
<------>at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1669)
<------>at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:45)
<------>at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
<------>at org.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:92)
<------>at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1652)
<------>at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:585)
<------>at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:143)
<------>at org.eclipse.jetty.security.SecurityHandler.handle(SecurityHandler.java:577)
<------>at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:223)
<------>at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127)
<------>at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515)
<------>at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185)
<------>at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061)
<------>at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141)
<------>at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:215)
<------>at org.eclipse.jetty.server.handler.HandlerCollection.handle(HandlerCollection.java:110)
<------>at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97)
<------>at org.eclipse.jetty.server.Server.handle(Server.java:499)
<------>at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:311)
<------>at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257)
<------>at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:544)
<------>at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635)
<------>at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555)
<------>at java.lang.Thread.run(Thread.java:745)


#4

That suggests that when completing the setup, your HTTP session cannot be found. I cannot explain this. None of the changes that were applied in version 4.1.5 are obvious causes for this either.

I’m unsure how to help you. Have you ruled out a fluke, related to removal/expiry of cookies and the like? Try running it again in a “privacy tab” of your browser.


#5

This error several days. I stumbled upon it on September 22, 2017
Changing the browser does not help, then there are no cookies.

It helps to change the version of the OF lower.
I tried 4.1.1, 4.1.3, 4.1.4 - on these versions webchat is a works.

When moving to 4.1.5 - webchat breaks down.
and starting work web-page http://xxx.xx:7070/ with one folder "ofmeet-cdn"
Inside the folder - I have text: Move on, nothing here…

I found this file in folder /usr/share/openfire/resources/spank/ofmeet-cdn

Perhaps the connection between these events does not exist …


#7

Yes, there is an issue loading Fastpath Webchat plugin in Openfire >= 4.1.5 .
Environment:

  • Windows 10
  • jdk1.8.0_144
  • Openfire >= 4.1.5
  • Fastpath Webchat 4.0.0

I’ve loaded .war in 4.1.4 and it works, not in 4.1.5 nor 4.1.6
Loading error message reminds me Websocket plugin install failed

It throws that on clear installation:

2017.10.06 21:37:38 org.jivesoftware.openfire.container.PluginManager - An exception occurred while loading plugin ‘webchat’:
java.lang.NoSuchMethodError: org.jivesoftware.openfire.http.HttpBindManager.getContexts()Lorg/eclipse/jetty/server/handler/ContextHandlerCollection;
at org.jivesoftware.liveassistant.WebClientPlugin.initializePlugin(WebClientPlugin.java:63)
at org.jivesoftware.openfire.container.PluginManager.loadPlugin(PluginManager.java:415)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:276)
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask$4.call(PluginMonitor.java:264)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)