powered by Jive Software

Webmeet anonymous login and Ofmeet won't work together

One question about Webmeet and Ofmeet.
Webmeet needs anonymous login enabled to work.
If I set this to true I’am unable to login to Ofmeet Meetings as registered User and it looks like I’m too a new or anonymous user. If I disable anonymous login, Ofmeet login works as expected but Webmeet dosn’t work anymore.

Any idea how to get booth working or there are settings in Ofmeet which will always authenticate registered users if anonymous login is enabled?

Maybe it’s possible to set up an anonymous account with password and set the password within the Webmeet ofmeet.js?

Thank’s
Michael

Additional Question. With Webmeet video chat where I’am if all is hosted on the local OF server? Webmeet Video chat points to jitsi and not to local OF server but I’m logged in on the local OF Server from Webmeet.
webmeet

If I set this to true I’am unable to login to Ofmeet Meetings as registered User

You should get a prompt to provide a username/password

Seems to me that your are mixing up two different use cases. External anonymous visitors to a web site use webmeet/ofmeet to communicate with internal authenticated advisers/agents who are using Pade or Spark with SparkMeet

The prompt for Ofmeet Meetings login appears only if I disable anonymous login but without anonymous login Webmeet dosn’t work.
External anonymous visitors should use webmeet/ofmeet and internal user should use ofmeet but internal user can’t login anymore ( no prompt for username&password) if anonymous is enabled.
To use the local OF server with webmeet I have changed the ofmeet.js to point to the local server’s ofmeet (instead of jit.si ) but with this change and the anonymous login isn’t possible to login to webmeet/ofmeet, same as a internal user can’t login to Pade.

I’d like to use webmeet/ofmeet for external user to communicate
with internal user Pade or webmeet/ofmeet.

Fastpath is not configured but will be the next step.

I use OF 4.6 + OFmeet 1.1.2 + latest webmeet

Any Idea?
Thank’s
Michael

If anonymous login is enable there are no prompt for username&password if I like to join a Ofmeet conference.
The only prompt is the question for the meeting password!
The console shows this error.

2021-01-11T16:06:33.652Z [modules/xmpp/strophe.jingle.js] getting turn credentials failed <iq xmlns=​"jabber:​client" type=​"error" id=​"e638404a-3b49-4d33-a952-44b3f9dc279d:​sendIQ" from=​"chat-1.radiologie.home" to=​"7tx1lxlp57@chat-1.radiologie.home/​7tx1lxlp57">​…​​<services xmlns=​"urn:​xmpp:​extdisco:​1">​​<error code=​"501" type=​"cancel">​…​​​
o @ lib-jitsi-meet.min.js:9825
(anonymous) @ lib-jitsi-meet.min.js:14752
(anonymous) @ lib-jitsi-meet.min.js:953
run @ lib-jitsi-meet.min.js:823
(anonymous) @ lib-jitsi-meet.min.js:1050
forEachChild @ lib-jitsi-meet.min.js:571
_dataRecv @ lib-jitsi-meet.min.js:1044
_onMessage @ lib-jitsi-meet.min.js:1721

lib-jitsi-meet.min.js:9825 2021-01-11T16:06:33.652Z [modules/xmpp/strophe.jingle.js] is mod_turncredentials or similar installed?

How I can fix this? Is there something missing?

Thanks!