Weird problem with IM client


I have openfire 3.5.2 installed on a ubuntu 8.04. I’ using a mysql database and the users authenticate via ldap. everything works fine except that current online status is not updated in the client software. I’ve tested Spark 2.5.8 and Pidgin 2.4.3 an 2.5.1.

Just to explained it in more detail: I’m online, if a user then login I can seethe online status via the openfire admin console immediatley, but not in my running IM Client. The user’s not shown there…

Has anyone a suggestion what’s going on?

Thanks for helping.


Just to verify, this worked in the past or is this a new install?

My suspicion is that you added buddies on the client side that are not valid Jabber IDs. Such that you added a buddy ‘buddy’ instead of ‘’


No this is a new install. The buddy name is ok.

Edit: Found a thread that is describing my problem.

By the way I installed the new version of openfire. hoped it solved. but the problem still appear. I have to logout to see the user status has changed.

Does no one has an idea how to solve that? It seems to be a problem with LDAP… Please

Is anything showing up in your log files?

I don’t have much experince with SQL databases, but maybe your clients aren’t being auto updated with the information from the SQL database, and are only getting it when they login…thats probably not the issue, but its a thought.

If you wait an extended period of time, do the clients eventually showup in your contact list after logging in, or do they just not show up period?

Have you recently cleared cache items in the web admin console?

I noticed a similar issue when I cleared all the cache items. I had to restart openfire and then everything worked fine.


I did serveral things but finally I decided to do a clean install. (openfire 3.6.0a).I switched now to the internal database. Just to test what Tim mentioned.

And now it seems to work. Unfortunally I can’t see the group members. So every user has to put everyone into the buddy list by hand.

The error log says:

2008.09.05 08:32:39 [org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroup(] Groupname Buddys not found at org.jivesoftware.openfire.ldap.LdapManager.findGroupDN( at org.jivesoftware.openfire.ldap.LdapManager.findGroupDN( at org.jivesoftware.openfire.ldap.LdapGroupProvider.getGroup( at at at org.jivesoftware.openfire.roster.RosterItem.setGroups( at org.jivesoftware.openfire.roster.RosterItem.setAsCopyOf( at org.jivesoftware.openfire.handler.IQRosterHandler.manageRoster( at org.jivesoftware.openfire.handler.IQRosterHandler.handleIQ( at org.jivesoftware.openfire.handler.IQHandler.process( at org.jivesoftware.openfire.IQRouter.handle( at org.jivesoftware.openfire.IQRouter.route( at org.jivesoftware.openfire.spi.PacketRouterImpl.route( at at at at at org.jivesoftware.openfire.nio.ConnectionHandler.messageReceived(

But in the group manager in the admin console everything look fine. I have a main group and serveral sub groups. Any suggestions?

Edit: I finally fount it: enable posixMode, and the Enable contact list group sharing. Then all member of the group are showing.

Thanks for all the hints.

Just wanted to mention that the posixGroup option was what fixed it for us as well (OpenLDAP server)