powered by Jive Software

Well I''m Baffled

Hello,

I’‘m using the spark clients. Most of the time the client installs just fine. However, I have two p.c. that are giving me some attitude. The client loads fine…but they can’'t get to preferences to enable things like popups / flash. Nor can the click on a chat room an enter in. It just sits there. Theses p.c.s are win2000. Driving me crazy. I knew I should of bought all “female” computers. Any help would be appreciated.

Thanks everyone in advance,

DJ

Hi djpratt,

Could you provide anything found in the spark_install/logs directory from those two computers. I’'ll take a look and see if I can get the fix in for 1.1.3.

-Derek

I’'ll look when I get to that end of the building.

Are there certain “services” that must be running or user permission? I can get it to work on the p.c. if logged in as Administrator of local domain. But not when logged on as user of network domain. It sure acts like it wants to work. Hmmmmm I’'m wondering if Java is on these old client p.c.s?

Thanks,

DJ

Hi DJ,

if you have a systeminfo.dll, tray.dll or jniwrap.dll file in %SystemRoot%\system or %SystemRoot%\system32 java will*) load it and not the ones which are delivered with Spark. Spark will start but it will usually not be usable.

( I don’'t know if this is still true for Spark 1.1.2.6 *)

LG

I had the same problem. It is caused by Spark looking for a registry entry (yes, still an issue in 1.1.2) for the currently logged on user in Windows 2000. This isn’'t an issue with Windows XP or if the registry key exists. See the thread: http://www.jivesoftware.org/community/thread.jspa?messageID=113173&#113173

for the real lodown on the problem, but if you create a registry file on the “problem” computers and merge it into the registry for the users (it is a per-user issue) it will fix the problem with preferences and not being able to send messages.

(You can make this a dummy entry as long as the “Spark” key exists if you don’'t actually want it to run.)

“Spark”=“C:
Program Files
Spark
Spark.exe”

I was told it’'s something to do with the “Start on Startup” settings.

I would LOVE to see this fixed in the next release.

Jimmy

Ah, Jimmy! I was finally able to reproduce this issue and will fix for 1.1.3. You can track it with SPARK-250.

Cheers,

Derek

You ARE my hero!!!

Thank you, thank you, thank you!

Jimmy

ok I figured it out. The program file of the clients didn’'t have write permisions. Funny how some would install but not all. Once I checked off it worked fine.