What version of OpenFire is required for Spark 3.0.1?

Our OpenFire server is version 4.5.1.
I have been running Spark 2.6.3 just fine on Windows 10.
I just upgraded my Spark client to 3.0.1. It will not launch.
Do I also need to upgrade OpenFire?


I appreciate your fast reply. If I upgrade OpenFire to the newest version, will that immediately break my Spark 2.6.3 clients? Or can I upgrade those PCs slowly to 3.0.1?

Since the Smack 4.4.X library strictly checks the connection, some older versions of Openfire may have problems.
Check it out:

Update openfire, then you update spark as problems arise.