powered by Jive Software

Where do I put the pyaim-t folder in wildfire?

I almost have this working, i’'m just wondering where I put the folder to get the transport to work.

Thanks a lot.

I also need help on how to detect this component on the wildfire server… i’‘m so close to having this AIM transport work but it’‘s getting frustrating and i’'m about to break my computer.

It doesn’‘t detect it even though I’‘m sure the config.xml file is right… i’'m so mad right now.

Please help me.

Hello,

pyaim-t is an external component so you could actually put it whereever you want. You don’'t have to and I think also should not put into a folder in wildfire! I have just a folder jabber and in there is wildfire and another folder components.

I had no problem setting up PyICQ-t and that it connects to jivemessenger, when I was trying it. Well, but I didn’‘t had luck to get PyMSNt connected. Haven’'t tried yet pyaim-t.

Good luck!

But how do I get wildfire to detect that pyAIM is running? I followed all the instructions, but I think my config.xml file is wrong.

Maybe you can past your config.xml file here.

Maybe you can past your config.xml file here.

I bet it will be a wrong value once again…

<!admin@host.com>

<!epoll>

<!kqueue>

<!poll>

<!xmlfiles>

<!mysql>

<!<xdbDriver_mysql>>

<!pyaimt>

<!pyaimt>

<!pyaimt>

<!localhost>

<!</xdbDriver_mysql>>

<!xmlfiles>

<!<xdbDriver_xmlfiles>>

<!encrypted>

<!</xdbDriver_xmlfiles>>

I am using the windows version of Wildfire and I followed the instructions for installing python and all that other stuff according to the AIM transport website.

Bump for great justice

Message was edited by:

solidsmooky

since the transports are external components, they talk to wildfire, wildfire doesn’'t go looking for them. wildfire has the ability to limit what external components can connect to it, or disable external components altogether.

to address the external component setup:

  • login to the wildfire admin console

  • under server settings, click on external components

  • ensure enabled[/b] is selected under “service enabled”

  • make sure the port/secret are set

  • under allowed to connect, select anyone[/b] (just for testing)

  • in the pyaim-t config.xml, make sure

i don’'t have mainServerJID or website specified in my config.xml. not sure if those would cause issues, but they do not appear to be required for the component to operate.

  • once config.xml looks good, restart pyaim-t

  • once restarted you can look under “component sessions” in the “sessions” area of the admin console to see if the component successfully negotiated a handshake

i’‘m using pyaim-t-0.6 and jive 2.3.0[/b]. i haven’‘t seen other component issues posted specific to wildfire 2.4.0, but i haven’'t had time to install it yet to verify the same setup is still valid.

hope this helps,

-chip