Where to get a usable hazelcast plugin for openfire 3.9.3


Now I can get the latest version of openfire 3.9.3, and download the hazelcast plugin (hazelcast.jar 1.3.3) from the official website Ignite Realtime: Openfire Plugins

But when try to upload the plugin, the stdoutt.log shows that: Ignoring plugin hazelcast: requires server version 3.9.4

The openfire version 3.9.4 has not released yet. I try to find the old version of those plugins but failed. Where can I get a usable hazelcast for openfire 3.9.3?

Thanks for reporting this. The plugins page should be in sync with the current release version. We will update the plugin web page shortly to refer back to the Hazelcast plugin version corresponding to the current Openfire release (3.9.3).

In the meantime, you can download version 1.2.0 with this link.


I also have to mention, that other plugins from Plugins page also refer to


For instance, Debugger Plugin.

So one have to rebuild plugins from current version (3.9.3) sources distribution. Which is quite simple, but not so convenient.

It would be nice to automatically fill *Plugins *page with plugins from sources of the current version, but not the current version of plugins (as I see in GIT repo, several plugins are set to 3.9.4 version there).

Hi Tom,

Is version 1.2.0 is still the latest for 3.9.3?

I tried the latest on site that is 2.0.0 and it also give same error.

I believe 1.2.0 is still the latest for 3.9.3. Even 1.3.3 (which was before 2.0.0) checks for 3.9.4.

1 Like

Where can I find the version of 1.2.2? I have the issue that when removing the clustering node but both parties cannot receive the message correctly.

I saw you have the fix from the 1.2.2 build.

Thanks a lot

Please find attached Hazelcast 1.2.0.
hazelcast-1.2.0.zip (2449340 Bytes)