powered by Jive Software

Wildfire 2.4.0 And Plugins

I upgraded to Wildfire yesterday and now I am having problems with all the plugins. They seem to get unpacked correctly, however they don’'t show up in the plugin page of the admin console. But if i delete the plugins .jar file and the directory it created, and then I re-copy the plugin into the plugin directory, the plugin never unpacks.

I upgraded to the latest version of all the plugins, so that probably isn’'t the problem.

Did this latest name change break plugins?

Yep, there was a namespace change to go with the name change, you have to redownload all the plugins, even if you already have the latest versions.

It’‘s sort of a pain, but it doesn’'t really take long.

I re-downloaded all the plugins and they still are not unpacking.

Hrm… and you removed the old jars and unpacked directories?

Strange… I guess we’'ll have to throw this over to one of the devs, ''cause that worked for me.

I did.

I’'m as stumped as you are…

Hi Caleb,

When you deleted the old plugins did you do it while Wildfire was running? You shouldn’'t have to, but have you tried re-starting Wildfire?

Thanks,

Ryan

I did, but usually the plugins directoy is locked and I can’‘t delete it. It wasn’'t this time. I could delete them while Wildfire was running.

I haven’'t tried restarting, yet. However our server rebooted this morning after auto-installing some patches. When it booted back up, none of the plugins deployed. They unpacked, but the were not in use.

Weird.

Ok, I set up another Wildfire server and did some testing, here is what I found:

The following plugins work with Wildfire 2.4.0:

Search 1.1.3

Spark Manager 1.0.1

User Import Export 2.0.1

The following plugins do not work with Wildfire 2.4.0:

Broadcast 1.3

Content Filter 1.0

Presence 1.1

Registration 1.2

However, the working plugins break if they are deployed with non-working plugins.

So if you have Wildfire stopped and you put the Search, Spark Manager, User Import Export and Broadcast plugins in the plugin directory and then start Wildfire, the working plugins will not load.

Also, deploying a non-working plugin seems to break the plugin loader on Wildfire.

So if you have Wildfire stopped and you put the Broadcast plugin in the plugin directory and then start Wildfire, working plugins will not load.

Hi Caleb,

I just checked in changes to each of the plugins so that they’'ll all work with Wildfire 2.4.0. The new versions will be as follows:

  • Broadcast - 1.3.1

  • Content Filter - 1.0.1

  • Presence Service - 1.1.1

  • Registration - 1.2.1

  • Search - 1.1.4

  • User Import Export - 2.0.2

The dates on all the plugins will be December 15, 2005, the day Wildfire 2.4.0 was released.

The new plugins will be available for url=http://www.jivesoftware.org/wildfire/plugins.jspdownload[/url] shortly.

Sorry for all of the confusion,

Ryan

New plugins uploaded. Thanks for your help Ryan!

-Matt

Hi guys,

Quick note on the plugins, the ‘‘Help’’ icon in the top right still doesn’'t display when viewing the plugins on the webpage.

Working path on normal pages is http://hostname:9090/images/header-help.gif

Non-working path on plugins is http://hostname:9090/plugins/userimportexport/images/header-help.gif

I know it’'s easily fixed by creating the images directory under the plugin and copying the image over, since the images folder is located in the ‘‘web’’ directory in the plugin directory.

Just thought I’'d point that out.

Leigh C