powered by Jive Software

Wildfire 2.4.2 and Broadcast plug-in

Good day!

We’'re using Wildfire 2.4.2 on a Windows 2000 Server with GAIM clients in k12ltsp and Windows 2000 / XP. All is working well for the 1.5 version of GAIM, except the “broadcast” feature.

I’‘ve tried ‘‘upgrading’’ to GAIM 2.0-beta, but it crashes on the windows workstations. So, I’'m trying to set up 1.5 to send an announcement to all users. I recall reading in another post about creating a JID (for the JETI instant messenger) such as: all@broadcast.SERVER and then sending a message to that ‘‘user’’, which would broadcast to everyone.

But since I’‘m using Wildfire, I can’‘t type all@broadcast.SERVER into the ‘‘Create a User’’ interface, because it doesn’'t allow that name.

Question: any suggestions on how to do this? (any ‘‘success stories’’ with GAIM 1.5)?

the all user is ‘‘virtual’’ just add all@broadcast.SERVER as a contact in your IM client and the message should be recieved by all users connected.

Atleast this worked for me using 2.4.2 on a Win2k3 server with my IM client being Pandion. Keep in mind that the message comes from which ever user sends it, so if you send it as yourself and have alot of IM users, you will get alot of replies (end user habit).

Yup, I tested this today. In GAIM, click Buddies - New Instant Message

And then use all@broadcast.SERVER pointing to your wildfire jabber account as the source and let the good times roll.

Thanks for the suggestions, MichaelD and AlexDeGruven! Both were tried:

  1. AlexDeGruven – I tried sending a message using the “New Instant Message” but nothing sent to other users. What version of Wildfire / Gaim combination do you use?

  2. MichaelD – adding the “all@broadcast.SERVER” (where SERVER is the IP Address of the Wildfire server) results in the “all” user being added to the Buddy list with the Subscription of “None (to pending)”. Is there a way to change this from pending to “Both” (like the other working members of the buddy list)? Makes me wonder if ‘‘broadcast’’ is working!!!

Have you used the administration console to lock down who is able to send broadcasts?

I was able to send a broadcast using GAIM 1.5.x and Wildfire 2.4.2

AlexDeGruven: No. When I did set up the (4?) properties of the plugin in Server Manager > System Properties, I couldn’'t log on to the jabber server from my client software; all was well when I removed these properties.

I currently have no broadcast properties in place. What settings are you using? Do I need to restart the Wildfire server after I add the properties?

plugin.broadcast.allowedUsers = me (I’‘m the admin, and we’'re still in beta)

Is currently the only setting I have set, right now. I can send a message to everyone who’'s signed in with just that setting.

I didn’'t have to restart wildfire to get it to work.

Did your GAIM ever say “None (to pending)” beside the “Subscription” status? I’'ve added the plugin, and it still has this.

Fixed! Although the buddy for “all users” says Pending, it still announces to all users. Fixed by adding “server name” instead of IP Address in the broadcast field…