powered by Jive Software

Wildfire 2.4/Spark - Server does not support VCards error

When attempting to update my profile using the latest Spark client, I recieve the following error message: Server does not support VCards. Unable to save your VCard.

My connection is closed after I acknowlege the error.

I recently upgraded from 2.3 to 2.4.

Is there a fix for this?

Thanks

I solved my own problem by recreating my account.

I am receiving the same error but with Spark 1.1.3 and Wildfire 2.5.1. Looking at the packets it seems that the spark client does not properly escape the characters such as ‘’&’’ when forming the xml packet using the entered vcard info. If I type in an address which includes something like ‘‘A&B’’ in my home address, then spark will get disconnected. If instead I enter something like ‘‘A&B’’ , while the server accepts it, spark does not recognize the returned vcard info and fails to load it up when I look up the profile again.

I’'ve checked in a fix to Smack, where the underlying bug resided:

SMACK-130

It will be updated in Spark when it is updated to the most recent version of Smack.

Cheers,

Alex