powered by Jive Software

Wildfire 2.5.1 Released

Wildfire 2.5.1 has been released . This is a bug fix release, but contains several important updates to improve performance and reliability. Change log can be found here[/url].

Enjoy,

Wildfire Team

Congrats!

-from the chat time reporter :stuck_out_tongue:

Greetings:

After upgrading our WAR based installation, it would appear that the admin pages are no longer working. A little digging uncovered that the compiled jsp classes which were duplicated from the admin-jsp.jar file are no longer duplicated in the wildfire.jar file as they had been in 2.5.0. While this works perfectly in our deployment of the standalone tarball version of 2.5.1, it doesn’'t seem to be happy in the WAR version running under Tomcat. Is there something that needs to be done regarding the configuration so that the compiled jsps can be found in the plugins/admin/webapp/WEB-INF/lib/admin-jsp.jar location?

Cheers,

-craig

Yeah,

I did try the .war file and to compile the sources, with the same result:

HTTP Status 404 - Servlet org.jivesoftware.wildfire.admin.index_jsp is not available


type Status report

message Servlet org.jivesoftware.wildfire.admin.index_jsp is not available

description The requested resource (Servlet org.jivesoftware.wildfire.admin.index_jsp is not available) is not available.


Apache Tomcat/5.5.12

QA did fail completely testing the .war release

May one expect a quick fix before weekend?

LG

May be, I might have been facing JM-593 in the past. I will update my test server over the weekends.

Thanks Devs

wmhtet

Hey guys,

The new wildfire_2_5_1.war file includes the missing pre-compiled pages. We fixed the problem almost after it was reported but for some reason the webserver was caching the old .war until now. I tried it locally and it is working fine. Let me know how it goes.

Regards,

– Gato

Hi Gato,

I’'m compiling from source and I did try the .zip and the .tar.gz, both still show this error. The compiled .war file is also a little bit smaller than the downloaded one which runs fine.

LG