powered by Jive Software

WildFire 2.6.2 + AD Problem

Hi !

I have installed Wildfire and cannot set up it to work with AD.

Wildfire 2.6.2 on FreeBSD 6 rel, AD - W2K SP4

Here’'s my config

Here’'s debug.log:

2006.05.11 15:05:02 Created new LdapManager() instance, fields:

2006.05.11 15:05:02 host:

2006.05.11 15:05:02 port: 389

2006.05.11 15:05:02 usernamefield: sAMAccountName

2006.05.11 15:05:02 baseDN: dc=sun,DC=rush,DC=dp,DC=ua

2006.05.11 15:05:02 alternateBaseDN: null

2006.05.11 15:05:02 nameField: displayName

2006.05.11 15:05:02 emailField: mail

2006.05.11 15:05:02 adminDN: Administrator@sun.rush.dp.ua

2006.05.11 15:05:02 adminPassword: swapo

2006.05.11 15:05:02 searchFilter: (sAMAccountName=)
2006.05.11 15:05:02 ldapDebugEnabled: true
2006.05.11 15:05:02 sslEnabled: false
2006.05.11 15:05:02 initialContextFactory: com.sun.jndi.ldap.LdapCtxFactory
2006.05.11 15:05:02 connectionPoolEnabled: true
2006.05.11 15:05:02 autoFollowReferrals: false
2006.05.11 15:05:02 groupNameField: cn
2006.05.11 15:05:02 groupMemberField: member
2006.05.11 15:05:02 groupDescriptionField: description
2006.05.11 15:05:02 posixMode: false
2006.05.11 15:05:02 groupSearchFilter: (member=)

2006.05.11 15:05:04 Loading plugin admin

2006.05.11 15:05:08 Loading plugin asterisk-im

2006.05.11 15:05:08 Asterisk-IM: Wildfire is using database type : hsqldb

2006.05.11 15:05:08 Asterisk-IM: Using Hibernate Dialect : org.hibernate.dialec>

2006.05.11 15:05:10 Asterisk-IM: Wildfire is using database type : hsqldb

2006.05.11 15:05:10 Asterisk-IM: Using Hibernate Dialect : org.hibernate.dialec>

2006.05.11 15:05:10 Loading plugin broadcast

2006.05.11 15:05:10 Loading plugin contentfilter

2006.05.11 15:05:11 Loading plugin presence

2006.05.11 15:05:11 Loading plugin registration

2006.05.11 15:05:11 Loading plugin search

2006.05.11 15:05:11 Loading plugin userimportexport

Please can anybody explain what I do wrong?

Lot of thanks,

Mykola

I would try setting the adminDN[/b] to an explicit DN like this:

[/code]

Done. Still not working

I don’‘t understand - it seems like Wildfire don’'t search in LDAP

No “Start search in LDAP…” message in log file

I had to use in order to get mine to work.

Also, the closing tag for your connection provider classname looks mutilated </className& gt;

Oh yeah… don’'t forget to remove the admin password from your log before posting.

Yeah, you’'re right

But still not working.

Go download LDAP Browser 2.6 from http://www.ldapbrowser.com/. Once you are able to browse AD with it, report back to us.

I can browse my other AD - 192.168.100.88 - v1.varus.dp.ua with LDAP Browser 2.6.

I change wildfire.xml :

LDAP connections log messages?

(I mean something like this:

…Trying to find a user’'s DN based on their username. sAMAccountName:…

2006.05.09 16:57:10 Creating a DirContext in LdapManager.getContext()…

2006.05.09 16:57:10 Created hashtable with context values, attempting to create context… )

Thanks

We found we had to use the sAMAccountName in the nameField… try something like this:

Was this problem resolved? If so, can someone please tell me how? I have the same problem and I have tried everything I can think of. Wildfire does not seem to even be reading the wildfire.xml file to get the LDAP configs… I have changed the authorized users to reflect the AD user, but I still need to use the built-in account.

The product works great with the manually created users, but I’'d really like to get it working with AD… any help would be greatly appreciated!

Here is my config:

NOTE: I have tried cn for the nameField, as well… also with no success.

Thanks,

Kyle

You did uncomment the ldap section right? Look for .