powered by Jive Software

Wildfire & JWChat: Internal Server Error

First off, I am very new to Wildfire and Jabber, for that matter. I have installed Wildfire 3.2.4 on an Ubuntu machine and can successfully access the admin console, so it appears to be running fine. I have also enabled HTTP Binding in Wildfire on port 8080 and setup a proxy rule in my Apache site config for /bind/ which also seems to be working.

In JWChat, when I try to login, an alert pops open with the error: “Internal Server Error. Disconnected. Reconnect?”. In the Firebug console, I can see the POST response is just the HTML of the /bind/ page. Also, when I try the simple example included with JSJaC, in the debug window I get an ‘‘initial response broken (status: 200)’’ error.

Any help would be greatly appreciated.

I have also tried JabberHTTPBind for binding and here is the POST response I get:

If you use the newest wildfire Server (not Openfire), you can use the RED5 plugin to get jwchat running out of the box. Just put red5 into your Wildfire plugin directory and visit:

http://www.yourserver:8080/red5

You can find the plugin here:

http://www.igniterealtime.org/projects/openfire/plugins-beta.jsp

Thanks, that definitely works.

But, I’‘m curious as to why my other setup still does not work and I think I’'ve narrowed it down to a binding issue. In my initial JWChat setup, I configured the proxy for /bind/ to point to http://servername:9090/red5/jwchat5, the same bind the Red5 JWChat uses, and it works. When I try visiting that URL, I get an XML parsing error, but when I would visit the Wildfire binding URL, I just get the “Wildfire HTTP Binding Service” header. Can anyone explain what might be going on? Why is the Wildfire binding not working correctly but the red5/jwchat5 is?

Hi there,

I´ve tried this but I always get:

HTTP ERROR: 404

NOT_FOUND

RequestURI=/red5

Powered by Jetty://

Wildfire´s Error-Log says:

2007.04.13 10:21:40 org.jivesoftware.wildfire.container.PluginManager.loadPlugin(PluginManager.java: 466) Error loading plugin

java.lang.UnsupportedClassVersionError: Bad version number in .class file

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClass(Unknown Source)

at java.security.SecureClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.defineClass(Unknown Source)

at java.net.URLClassLoader.access$100(Unknown Source)

at java.net.URLClassLoader$1.run(Unknown Source)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(Unknown Source)

at org.mortbay.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:354 )

at org.mortbay.jetty.webapp.WebAppClassLoader.loadClass(WebAppClassLoader.java:325 )

at org.mortbay.jetty.handler.ContextHandler.loadClass(ContextHandler.java:978)

at org.mortbay.jetty.webapp.WebXmlConfiguration.initListener(WebXmlConfiguration.j ava:624)

at org.mortbay.jetty.webapp.WebXmlConfiguration.initWebXmlElement(WebXmlConfigurat ion.java:366)

at org.mortbay.jetty.webapp.WebXmlConfiguration.initialize(WebXmlConfiguration.jav a:288)

at org.mortbay.jetty.webapp.WebXmlConfiguration.configure(WebXmlConfiguration.java :221)

at org.mortbay.jetty.webapp.WebXmlConfiguration.configureWebApp(WebXmlConfiguratio n.java:179)

at org.mortbay.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1188)

at org.mortbay.jetty.handler.ContextHandler.doStart(ContextHandler.java:481)

at org.mortbay.jetty.webapp.WebAppContext.doStart(WebAppContext.java:434)

at org.mortbay.component.AbstractLifeCycle.start(AbstractLifeCycle.java:40)

at org.jivesoftware.wildfire.plugin.red5.Red5Plugin.initializePlugin(Red5Plugin.ja va:234)

at org.jivesoftware.wildfire.container.PluginManager.loadPlugin(PluginManager.java :404)

at org.jivesoftware.wildfire.container.PluginManager.access$200(PluginManager.java :46)

at org.jivesoftware.wildfire.container.PluginManager$PluginMonitor.run(PluginManag er.java:920)

at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknow n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Any idea why red5 does not work for me ?

Thanks and regards

Bjoern