powered by Jive Software

Wildfire server on intranet - error "failed to create connection to remote

I’‘m new to wildfire server, and installed it on Ubuntu 6.10 for a client. on their private netowrk. Instllation went ok. I have 2 users on the system - myself and user2. When I lot on, I’'m shown in the user summary as logged on, as is user2. In gabber,

tuser2 is seen in both the Pending and the Buddies list (for me). When I try to send a message to user2, gabber (and gaim) die, and I get the error: failed to create connection to remote server in the wildfire logs. Can anyone help me with this problem? The network works on (as I can see both users), no firewall, etc. Why this error message? Can anyone help?

Hi,

how do you add users to your roster? Did set the xmpp.domain to example.com and are you trying to chat with "user2@example.com"?

If you are using another domain like “user2@ip.ad.dre.ss” then the server will try to create a s2s connection and this will likely fail.

LG

Where do I set the xampp domain? This might be the problem…

System Properties allows you to change it. But if you change this all roster entries which contain the current server name will fail.

LG

the xmpp.domain is admin.net. I enter my users as “user1”. My login id is then set to "user1@admin.net". I can see the user1 in the User Summary page, and can even send it an admin message. The problem comes in when I try to chat with user2 (who is set up with login id user2@admin.net). When I pull up a chat window and send a message, the debug window says “trying to connect to admin.net: 5269, DNS lookup: admin.net… Error sending packet to remove server.”

Why is it trying to connect to admin.net when the server name is kathy.admin.net (verified in server settings and both users account prefs).

Any ideas? I’'m sure this is much easier than I am making it…

Hi,

you can choose your xmpp.domain and set it to whatevery you like. Some users run Wildfire behind a router with a public IP address (for example 63.246.20.124) on a server with a private address (like 192.168.3.4).

They will usually have an internal servername which must never be published in the internet (like our-xmpp-server.jivesotware.com). They create a public DNS entry “jivesoftware.com” which points to the public IP address and they set the xmpp.domain also to “jivesoftware.com”.

So Wildfire does not know or at least it ignores the internal servername, messages to "user@jivesoftware.com" are routed to “jivesoftware.com”, whereever this is.

So it seems that your Wildfire server can not resolve “admin.net” or it gets a bad IP address. It may help a lot to edit your hosts file and add there a line “127.0.0.1 admin.net”.

Did you install Wildfire using another xmpp.domain? The installer has problems if the xmpp.domain can not be resolved.

LG