powered by Jive Software

Wildfire server rejecting connections

Hello,

Installed the rpm package ‘‘wildfire-2.4.4’’ and after setting up the server, clients are unable to connect. The error log shows;

2006.02.06 12:11:47 org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:159) Connection closed before session established

Socket[addr=/192.168.0.122,port=52355,localport=5269]

This is running in Suse Linux 10.0 and there is no firewall on the server. Any suggestions on how to fix this?

Thank you in advance,

James

Hi mrirh,

are your clients connection to port 5269? This is the server-2-server port and should not be used by clients. Are there any other errors or could you retry connecting to port 5222 or 5223 ?

LG

Hello it2000,

Thank you for your reply. All clients are attempting to connect through port 5222. I found this in the warn log;

2006.02.06 12:37:39 Closing session due to incorrect hostname in stream header. Connection: org.jivesoftware.wildfire.net.SocketConnection@1c8b884 socket: Socket[addr=/192.168.0.122,port=56642,localport=5269] session: null

I just disabled the ‘‘server to server’’ component and user accounts were added through the Admin console on port 9090. Also had the client app try to connect to the secure port, which gave an error that the certificate was invalid (client is, therefor, talking to server) although afterwards the client never connected to the server. Very odd.

Thank you.

Hi mrirh,

“incorrect hostname” let’'s my think of “_” in DNS names. Or the “to” attribute is missing in the XMPP stream. Are you able to trace the XMPP packets which are exchanged?

LG

Hello it2000,

How do I trace XMPP packets? Also, all clients connect with username@xxx.xxx.xxx.xxx (where ‘‘x’’ is the IP address) so there is no DNS look up.

Thank you

Hi,

some clients allow to trace the packets. Also Spark allows this after you logged in, but not during login so Spark can’'t help you.

Did you enable the debug logs in Wildfire, maybe there you can find some more valuable information.

LG

Hello it2000,

Debugging was disabled, but not any more. Things may be looking up. From the debug log;

2006.02.06 13:57:46 Connect Socket[addr=/192.168.11.16,port=3236,localport=5222]

2006.02.06 13:57:46 Error sending packet to remote server:

java.lang.Exception: Failed to create connection to remote server

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.createSessionAndSendPac ket(OutgoingSessionPromise.java:139)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise.access$300(OutgoingSess ionPromise.java:37)

at org.jivesoftware.wildfire.server.OutgoingSessionPromise$1$1.run(OutgoingSession Promise.java:91)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

Thank you.

Hi,

this is once again a server2server exception.

It seems that your client has IP 192.168.11.16 and the server has IP 192.168.0.122.

Is it a 255.255.0.0 or a 255.255.255.0 subnet?

Actually you did specify a server name during setup. You added a user “john”, which has the JID “john@specified_server_name”.

Maybe you can change the server name (System Property xmpp.domain) to it’'s IP address and restart it?

LG

Hello it2000,

Your suggestion put this in the right direction. Isn’'t this a client2server issue rather than a server2server one? Both subnets are 255.255.255.0. The server name was modified several times although the client was connecting to the IP address and not the name.

I added the server’'s name to my local hosts file and changed the client to use username@hostname and it now connects to the server. Thank you very much!

This was not an issue with previous versions of Jive. Is there a way I can fix this, server side, as I do not wish to modify host files for every client. The Admin page would not save the Server name as an IP address.

Again, many thanks for your generous help.

Hi,

yes it is a c2s issue, you can believe me that the s2s exceptions were very odd and I did really wonder what’'s going on.

Why don’'t you set up a DNS record, so all your clients can use it?

You should be able to change the server name to the IP address by modifying the database content using SQL, but I think that this is not recommended.

LG

I added the server’'s name to my local hosts file and

changed the client to use username@hostname and it

now connects to the server. Thank you very much!

This was not an issue with previous versions of Jive.

Is there a way I can fix this, server side, as I do

not wish to modify host files for every client. The

Admin page would not save the Server name as an IP

address.

Yes, there were some changes made for more strict handling of servername. But i thought it’'s only affecting s2s. Then using s2s you must use username@servername form then adding contacts. But for a local use IP should still work.

Well, i’'m with Wildfire 2.4.4, it has static IP - 192.168.12.41 and “jiveserver” name in server rc.conf and a line in hosts:

127.0.0.1 localdomain jiveserver

In Admin Console it’'s named jiveserver also.

When connecting new users i use username@jiveserver (and host: 192.168.12.41) in Exodus. But a lot of users are still logging as username@192.168.12.41 and it works. s2s is disabled. Maybe i’'m mising something about your problem?

P.S. BTW there were no mentions about that change in servername handling in changelog? I cant find anything about that, nor cant find a thread where we were discussing it with Gato.