Wildfire.xml interface binding

I have recently installed Wildfire 3.1.1 on a FBSD 6.1 server from the FreeBSD ports collection. The server works very well. The one main problem that I have encountered is that I would like to bind the web admin GUI to a specific IP address rather then having the web server listen on port 9090 on all interfaces. I have set an IP address in the “interface” field in the wildfire.xml file, but the web server still listens on all interfaces. This is also the case for the jabber daemon. Is there any way to force the web gui to listen on one IP and the jabber daemon on a different IP? I can always enforce these rules through the use of a kernel firewall, but it would be nice to be able to further lock these things down at the application level. Thanks for any suggestions on this inquiry.


setting jive.network.interface in wildfire.xml should bind all services to the specified IP address, but you need to restart Wildfire. So you can bind Wildfire to the internal interface and then you need a connection manager or a TCP proxy which binds to the external interface and connects to Wildfire.


The “interface” section was commented out by default in the wildfire.xml that comes w/ the FBSD ports collection. Just had to look closer @ the file to find my own issue. Thx.