Windows 7, new chat window goes black!?

Hi all,

One of my friends on our network is having an unusual problem with her chat window going black. Her iMac is running Windows 7 Home Premium 64-bit via Boot Camp (for finance/accounting purposes), and every time someone sends her a chat message, the chat window that usually pops up fine now comes up completely black. When hovering over the window, the cursor will change, indicating that the functionality is still in the window, but it is basically unusable.

Any idea what might be going on here, and how to fix it?

What version of Spark?

Spark 2.5.8 for Windows

You can try 2.6.0 Beta 2 on this machine. Also you can try deleting that user’s profile in C:\Users\Username\Spark and starting over.

Sorry to resurect such an old thread but this has been driving me crazy as well. I am running Windows 7 64bit and have this same problem. The chat window will be completly black and can not be closed but appears to be still working in the background. It only seems to happen to me when recieving a new message while Spark is minimized to the tray. Eventually I will have to end task on Spark to get it to go away. Has anyone else experianced this and know how to fix it?

I have tried:

  1. Uninstalling (removing profiles, checking the registry, removing all folders.)

  2. Installing different versions (Latest trunk, 2.6.3, 2.6.2)

  3. Java 6 & Java 7

  4. Luna Theme and Various Swing Themes.

  5. Updating Graphics drivers.

  6. Increasing Java Heap Size in the build.

  7. Disabling Flashing (as this has a 64bit specific dll)

I was trying to remember the last time this worked without issue and I think it was 2.6.0 RC2. I have back dated to that today and will see if I have the problem again. I am wondering if it might be something with the interface redesign for Luna or the otr plugin, but being this was reported on 2.5.8 above, now I am starting to doubt this theory.

Any help would be appreciated.


I am new to the forum. I was looking for a solution to the same thing George is having an issue with. The only thing different is Spark is being ran from a Windows 7 32 bit machine. I have had the same issues. I’ve checked though the event logs to see if I could find anything that matched when we were having an issue. Has anyone else had the same issue or came up with a work around? Thanks everyone.

You could try do disable gfx acceleration.

  1. See

If the Spark.vmoptions works (GC log written) then you can add




``to it.

  1. If the Spark.vmoptions does not you could try to use this start script and change the line ``start “” “%app_home%%my_spark%” org.jivesoftware.launcher.Startup %autologin%´ to `

start "" "%app_home%\%my_spark%"-Dsun.java2d.ddoffscreen=false -Dsun.java2d.d3d=false -Dsun.java2d.noddraw=true ``org.jivesoftware.launcher.Startup %autologin%´`

  1. Another option may be to disable gfx acceleration in the gfx driver.

Awesome. I will give this a try and report back. Thank you for the response.

yes, I had the same problem, I will try to find a solution…

So far so good. I have run this the last few days and it seems to be working. I use launch4j as part of the innosetup package so I edited the launch4j template xml to add the additional options.