powered by Jive Software

Windows Server 2008 blocking issues

Hello,

Didnt expected that installing openfire and spark with xampp would go so EASY but the only issue currently i am facing right now is the SPARK works for users only when the SERVER 2008 firewall is OFF, i tried to do the INBOUND/OUTBOUND rules on 5222,5223 but didn’t worked infact allowed SPARK as exceptional but still. If someone can help me out. Thanks.

Usually it’s enough to open 5222 port on the server (at least it is enough with iptables firewall on my linux box). I think it was enough when i was testing on WinXP box also. Maybe you should add Openfire.exe to the exceptions.

Honestly, this is what i did and tried so far. But still it works only if i switch off the firewall completely on Windows Server 2008. Strange

Can’t test it on Win2008. Maybe some other rule or policy is blocking such connections.

One thing is confirm that it works only when i switch off the firewall and i don’t have any strong routers to block ports or do the scanning. Still gonna delete existing rules and create inbound/outbound rules again and let u know in few inutes. Thanks for your instant responses.

Another thought that this could be the outbound rule blocking the Openfire responses, as it can response from a random port every time. Only the incoming connections are received on 5222.

Alright, double checked by creating INBOUND/OUTBOUND & creating seperate rules for TCP/UDP but it is the same issue. It only works when the firewall is switched off. Strange, why Windows has to be so complicated sometimes.

Any help Wr00t

I have tried to install Openfire on a test Win2008 server (domain member, so i can’t even disable a firewall). I wasn’t able to login to Openfire until i have added an exception for the 5222 port in this server’s firewall. Didn’t do anything else and this is a default Server installation with no special firewall settings (File and Printers Sharing, Remote Desktop, Network Discovery, Core Networking are enabled in the exceptions). Din’t look in to Advanced firewall configuration.

Thanks for your instant response, But i think if you want to add any port in firewall ADVANCED FIREWALL CONFIGURATION is the only place to do that otherwise there is only an option for PROGRAMS to be in exceptional category. Is it ?

No, there is also the Add Port button along with the Add Program in the basic Firewall configuration (Exceptions tab).

Hi WrOOt sorry i wasn’t online so took longer to post the results over here. Well the one you are talking about is for Windows XP but for Server 2008, adding ports are for Advanced Firewall Settings only and not in ALLOW A PROGRAM THROUGH FIREWALL category. Tried, and it is still working only when the server firewall is disabled.

win2k8_fw_addport.jpg

I’m talking about this. As you can see, this is Windows Server 2008. Are you using older 2008 version or R2? Because these a quite different systems, though sharing the name.

I am using R2 64bit Windows 2008 Server.

Hey Ibrahim,

i’m running my public openfire server on a windows server 2008 (32bit) machine and i never touched the Firewall settings or opened any port. The Windows firewall is turned on.

What other services do you run? Maybe some other service is using the port? Are S2S connections working properly?

Hi, actually it is for Domain users. I tried and no other services or programs are using the same port. Can you tell me about the S2S more ?

Can somebody please help me out with this, thanks.

I ran into the same problem on my R2 server. Added the Openfire Server to the exception rule on the firewall still it didn’t work. Disable the firewall completely then it work. Then I said okay fine. Since it is working let me add port 5222 inbound and accept all traffic(This is with the firewall disable). Then I enable the firewall for kicks to see if it is still block.

Luanch client to test to see if it was blocked and guess what? The client connected.

It worked for me so you might want to try it. The other thing I was looking at was running a netstat -a -b to see what is using port 5222 and windows could not identify the program.

1 Like

I did this exact same process and it worked fine for me. I also opened up port 9090 to enable remote administration access.

Wow, now it looks like my long awaited problem is going to solve soon if i keep having the expert comments. Definitely i am going to give it a try because i had almost lost hope but i will give it a try this weekend. Thanks.