powered by Jive Software

Xabber Delivering only one way chat

Whenever i initiating a chat with user, the recipient gets delivered,but when he/she try to reply back the message not getting delivered ,say A sends message to B, B getting delivered .If B tries to reply , A not able to receive the message. Previously it works fine, From last few days happening like this. Any Suggestions please

Works fine for me when sending messages between Xabber and Spark.

i have the same problem

Xabber is the problem… now i’m using Conversations and it works.

i think Xabber cannot talk to Xabber

Ok, i’ve got another Android tablet and was able to reproduce this. Strange issue. Not sure whether it is Openfire’s or Xabber’s fault. But Xabber can chat normally with Spark. Also Yaxim works fine on both tablets. This is only happening when you use Xabber to chat with another Android tablet. Maybe this is some Android update messing around. Anyway, i have filed a ticket with Xabber Can’t send second message using Openfire 4.0 server · Issue #618 · redsolution/xabber-android · GitHub

I also have this issue, but between Xabber and Trillian. Spark, Pidgin, and Psi all seem to work normally. I have started to use Yaxim and it works fine with Trillian. Conversations worked fine as well.

Just tested this with Xabber Beta and the same issue occurs. Reported this to Xabber developers. Waiting for an answer.

Have the same issue.

Downgraded to 3.10.3 and found that plugins no longer supported.

But I get some plugins from backup. .jar files:

  1. broadcast.jar
  2. clientControl.jar
  3. contentFilter.jar
  4. dbaccess.jar
  5. emailListener.jar
  6. justmarried.jar
  7. loadStats.jar
  8. monitoring.jar
  9. motd.jar
  10. packetFilter.jar
  11. search.jar
  12. userImportExport.jar
  13. xmldebugger.jar
    Contact in pm for it.

Any one has good news about this bug? Its openfire bug or xabber need to be fixed?

Or is there any setting in openfire to solve this issue?

I got this log, what its mean? I think this is Openfire bug that should be fixed

*2016.08.18 22:43:08 org.apache.mina.filter.codec.ProtocolCodecFilter - Processing a MESSAGE_RECEIVED for session 887 *

*2016.08.18 22:43:08 org.jivesoftware.openfire.spi.RoutingTableImpl - Failed to route packet to JID: x2@fortunecells.xyz/android packet: Uwn7wj7j22nnie8wk8wuhe< thread>6rbU4I4j965k *

*2016.08.18 22:43:08 org.jivesoftware.openfire.MessageRouter - Message sent to unreachable address: Uwn7wj7j22nnie8wk8wuhe< thread>6rbU4I4j965k *

*2016.08.18 22:43:09 org.apache.mina.filter.ssl.SslFilter - Session Server856: Message received : HeapBuffer[pos=0 lim=37 cap=64: 17 03 01 00 20 EB 33 74 85 C9 A3 F7 17 1E A0 CD…] *

*2016.08.18 22:43:09 org.apache.mina.filter.ssl.SslHandler - Session Server856 Processing the received message *

*2016.08.18 22:43:09 org.apache.mina.filter.ssl.SslFilter - Session Server856: Processing the SSL Data *

*2016.08.18 22:43:09 org.apache.mina.filter.executor.OrderedThreadPoolExecutor - Adding event MESSAGE_RECEIVED to session 856 *

Queue : [MESSAGE_RECEIVED, ]

I’ve been using Xabber for about a month now with no issues whatsoever.

Pretty decent client.

I’ve been using Xabber 1.0.30 currently. Been using it for a month or so now with no issues.

  • What Openfire version do You use?

  • What OS?

  • What client You chat with Your own Xabber?

1.) Xabber version listed above in reply to OP: 1.0.30 (sorry for the confusion)

2.) Android 6.0.1

3.) Xabber is the client I’m using on Android. Spark on the PCs.

4.) Opensfire 4.0.3

I think Xabber only can chat in 2 ways only if the other client support for TLS/SSL enabled and some Encryption Cipher Suites that Openfire used. Need more research for this.

I’m using neither. Do you have all the correct ports open?

  • Port 9090 : for the web interface.
  • Port 9091 : for SSL web interface.
  • Port 5222 : the main port used for client/server communication by Openfire.
  • Port 7777 : used for file transfer.
  • Port 7443 : used for unsecured Http client connections.
  • Port 7070 : used for secure Http client connections.
  • Port 3478, 3479 : used by the STUN Servive for entities behind a NAT.

Your mentioned ports are open, except this one:

  • Port 3478, 3479 : used by the STUN Servive for entities behind a NAT.

The issue seems to be fixed in the latest version (2.x), along with some other issues.