XIFF and ejabberd

Hi All!

Did anybody use XIFF with ejabberd server? I’‘ve got some problems with it. I tried to use XIFF AS2 but for this reason I should patch the server http://ejabberd.jabber.ru/flash-hack. I did patch it but XIFF still can’‘t work properly with it. I tried to use XIFF AS3 with XMPPSocketConnection. But can’'t login to server. I just wonder does somebody works with XIFF and ejabberd server? If yes then how he solve this problem?


Apply patch (see http://ejabberd.jabber.ru/node/320 , it works!)

Try with XIFFIAN,

Check server configuration with another client,

Check presence of crossdomain.xml on the root of the web server (on the jabber/jive machine)

Good luck!

Patching doesnt work for 1.1.2 server. Could you provide more detail information?

Could you try this patch (no garantee, it compiles, but I cannot test it, I got an error configuring ejabberd…): http://usuc.dyndns.org/tv/xiffian/ejabberd_1.1.2-flash.patch

If it works, I’'ll submit it to ejabberd.

No, it doesn’‘t work. Can’'t compile it.

What’'s the compilation error message? It did compile well on a kubuntu distribution once all dependencies were resolved and installed

Can’'t compile it on Fedora 6, but compiled on Fedora 5. Tried to connect from the flash but stream was closed. Here some log;

=INFO REPORT==== 26-Jan-2007::16:54:48 ===


I configured my ejabberd server (on kubuntu) again, and it works…

Your problem seem to be somewhere else…

Could you send me the ejabberd_c2s.erl for me to see what difference can be present…

Just paste the content of your file here: http://usuc.fr/index.php/show/_contact

Did you applied other patches?

Does it work with other client (I tried with Kopete)?

I configured my ejabberd server with such patches:



with options: --enable-odbc --enable-flash-hack

I compiles it on Fedora, but on Fedora 6 I can’'t compile. Tried server with Miranda and Tkabber and it works.

Message was edited by: black

So, any progress in this case?