powered by Jive Software

xmpp.muc.history.maxNumber

Hello Everyone,

I am new to openfire, In group chat scenario, if the third guy will join only 25 messages is loading(as it hardcoded in java code).

I added this property(xmpp.muc.history.maxNumber) with 100 messages in openfire.script, and restarted openfire service.

But it still showing only 25 messages,

I tried using admin UI it works fine.

Is there anyway. so that i can update in backend and it will load updated (xmpp.muc.history.maxNumber).

Hi!

Try to change GroupChat History Settings (This will affect all conferences for that groupchat service)

Follow GroupChat->Groupchat Settings->choose a service (default is conference) -> history settings.

Thanks Grigori,

I know that, using Admin UI we can update.

I want something like update in openfire.script

I tried

INSERT INTO OFPROPERTY VALUES(‘xmpp.muc.history.maxNumber’,50)

But it was not working.