powered by Jive Software

Yahoo! Transport going offline?

I’m running Openfire 3.3.3, and 1.1.3a gateway… MSN/AIM transports are working quite well. However the Yahoo! transport is having some issues.

Someone behind the gateway shows up as available for a short while on the normal Yahoo Messenger, then they suddenly “go offline”, even though they are not (seems like some sort of false timeout?)

And on the Openfire side, Yahoo contacts always show offline, they never show online. However until the transport “goes offline”, the two parties can carry a conversation.

Anyone have thoughts as to this behavior?

Tools tried include the Yahoo! Messenger itself, Pandion and Pidgin on the Openfire side.

Hrm. I make use of all of the transports and haven’t seen this before. Strictly with Yahoo huh… that’s odd. Do you have debug logging enabled in openfire? It might help to see what’s going on from the logs.

I met similiar problem. Here is the log:

2008.01.11 16:32:01 [org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSes sion(LocalOutgoingServerSession.java:258)

] Error trying to connect to remote server: yahoo.com(DNS lookup: yahoo.com:5269)

java.net.SocketTimeoutException: connect timed out

at java.net.PlainSocketImpl.socketConnect(Native Method)

at java.net.PlainSocketImpl.doConnect(Unknown Source)

at java.net.PlainSocketImpl.connectToAddress(Unknown Source)

at java.net.PlainSocketImpl.connect(Unknown Source)

at java.net.SocksSocketImpl.connect(Unknown Source)

at java.net.Socket.connect(Unknown Source)

at org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSess ion(LocalOutgoingServerSession.java:253)

at org.jivesoftware.openfire.session.LocalOutgoingServerSession.authenticateDomain (LocalOutgoingServerSession.java:143)

at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.sendPa cket(OutgoingSessionPromise.java:205)

at org.jivesoftware.openfire.server.OutgoingSessionPromise$PacketsProcessor.run(Ou tgoingSessionPromise.java:185)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)

at java.lang.Thread.run(Unknown Source)

That last error log looks like someone tried to add like… ninja@yahoo.com instead of ninja@yahoo.yourxmppserver.org

So Openfire is attempting to contact yahoo.com directly and since yahoo.com does not run an XMPP server, the connection is rejected.

I wish there was a link to documentation.

The jabber-id for yahoo is shown as : someone@yahoo.my-xmpp-server-url
I have the following questions :

  1. Is this the required format?
  2. Do I have to pre-create these id’s in my-xmpp-server

Regards & Thanks

P G Patrudu

I think I got it. I see yahoo.my-xmpp-server-url in gateway settings.