powered by Jive Software

Yet another OpenFire Base DN question

Sorry everyone. I’ve read the forums and just can’t get my base dn to work. Every test I’ve tried, I never get a response from the server, so I can only assume that I’m not even close enough to get a valid test.

Server type is Active Directory

Host is the primary AD server (example: AD2)

My Base DN reads: cn=“Test Users”,dc=city,dc=egypt,dc=local That being city.egypt.local with an cn of Test Users

My Admin DN reads: cn=administrator, cn=Users,dc=city,dc=egypt,dc=local That being the domain administrator in the users cn, in the domain city.egypt.local

When I do this and hit test settings, nothing happens.

Any ideas?

make your base dn the root of your AD

then use filters to filters to control security

the for admin, just use administrator@domain

Just go ahead without testing in order to test :slight_smile:

On my 3.8.1 installation the “Test settings” button did not work either on any browser on Wiondows or Mac OSX. But still the server worked fine afterwards. Perhaps the button has bug in the release!?

Can you example that? Base DN would read: dc=city,dc=egypt,dc=local ?

As for the Admin dn, are you suggesting I simply make the whole line read administrator@city.egyadministrator@city.egyptadministrator@city.egyptadministrator@city.egyptpt.local ?

man did that mess up:

Admin DN: administrator@city.egypt.localadministrator@city.egypt.local

I got an error I don´t know if my solution will gonna help you, sorry this late reply but if you have another server of openfire and you´re setting up a new one try to shutdown the old one for an while and setup the new one, some ports are by the old openfire server and when you´re setting up a new server it´s impossible to communicate with LDAP server because the ports are currently in use.