powered by Jive Software

Yosemite (MAC) and OpenFire -Latest Build

I have downloaded and installed the application, researched thru the discussion forums and tried correcting execution of openfire.sh but the application will not start.

Considered deleting OpenFire for Mac and installing *nx version but not sure its worth the effort.

Has anyone been able to get this working on recent MAC OS X build?

PS, we are running the latest Server app on this system.

Thank you.

I’ve had similar problems with Mac Lion. I ended up with the Linux Installer and started Openfire from command line, which worked better.

After installing latest OpenFire on latest Mac OS X Yosemite, the server does not start.

Looking in the error log in /usr/local/openfire/logs/launchd.stderr the following Exception is thrown:

Exception in thread “main” java.lang.UnsupportedClassVersionError: org/jivesoftware/openfire/starter/ServerStarter : Unsupported major.minor version 51.0

at java.lang.ClassLoader.defineClass1(Native Method)

at java.lang.ClassLoader.defineClassCond(ClassLoader.java:637)

at java.lang.ClassLoader.defineClass(ClassLoader.java:621)

at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)

at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)

at java.net.URLClassLoader.access$000(URLClassLoader.java:58)

at java.net.URLClassLoader$1.run(URLClassLoader.java:197)

at java.security.AccessController.doPrivileged(Native Method)

at java.net.URLClassLoader.findClass(URLClassLoader.java:190)

at java.lang.ClassLoader.loadClass(ClassLoader.java:306)

at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)

at java.lang.ClassLoader.loadClass(ClassLoader.java:247)

There is no mention in the “System Preferences” launcher for OpenFire as to why the server can not start.

I think this would be a very common problem on the Mac 64-bit Yosemite platform that everybody would run into.

Has anybody solved this yet?

Sincerely,

Don Wood

“Unsupported major.minor version 51.0” means you are using Java 6, and Openfire needs Java 7 at least.

I am using Java 8, but I also met the problem above, that is, the error log also says “Unsupported major.minor version 51.0”. What should I do? Restore Java 7?

Then Openfire can’t see your Java 8. But i don’t know how to point it to. You can try restoring Java 7, maybe it will work.

I meet this error too. It doesn`t work even i restore to java 7.

I have fixed it, but I don’t know wether it can help you. In my situation, there’s something wrong with my ‘JAVA_HOME’.

Just open terminal and text “sudo su” to enter the admin mode(then you will need to enter your password). You can see my following steps in the picture below. Hope it works.

What version does it return if you enter this?

java -version

I now have my JDK 1.8 installed from the .dmg download from Oracle.

I had to edit the symbolic link /usr/bin/java to point to the latest version just installed instead of the former 1.6 version.

Sadly the install location and the process for upgrading to a later level changed since v1.6 and is no longer a consistent pattern to follow.

Openfire starts and I can get to the control panel but none of my former user account that use Spark 2.6.3 can login.

I am able to reset the account passwords in the administrative screens so the problem isn’t related to wrong password.

Will look elsewhere for posts about Spark clients not being able to login.

If you always use this approach.You will launch the setup page everytime, Even you have set up it.

I follow your steps, but the display ‘permission denied’…

屏幕快照 2015-06-10 下午1.13.05.png

chmod 777

Thx! My problem has been solved.

屏幕快照 2015-06-11 上午10.53.55.png

1 Like

It is because of Java version mismatch. Unsupported major.minor version error happens when you compile your projects on higher version of java(e.g. jdk 1.8) and then run it on a lower version (e.g. jdk 1.7). Depending on your situation, you have two ways to resolve this error: compile your code for an earlier version of Java, or run your code on a newer Java version. Sometimes you may have more than one version of Java SDK installed in your machine. Make sure the application you are running is pointing to the right or highest version available . It is better you need to install both JRE/JDK with the same version.