powered by Jive Software

Zabbix + Jabber = Not working

Hello.
We have Zabbix the latest version and Openfire server the latest version. Everything is configured.
Settings of Openfire by default.
Openfire server is available from server Zabbix.
When Zabbix trying to send a notification to Jabber Zabbix gets an error
[B]SASL authentication failed[/B]

Help solve the problem please! Thank you

P.S. When we try Ejabberd server - Zabbix received the same error

Hello all,
I have the same error during setting up jabber(openfire) notifications.
In older versions of Zabbix I have seen variable responsible for using ssl auth.
Depending if it was set to 0 or 1, ssl was used or not.
In my case, I have installed 3.2.11 version of ZBX but in this version I cannot found this parameter. Probably there is other way to turn off ssl auth.
Maybe someone from You had the same problem and want to share resolution?
I would be grateful for any tips.
Thanks in advance.

Regards,
Michal

I ran into this not too long ago. the issue is with the client included with zabbix. its an old client and can’t handle tls correctly. The work around was to install a commandline client called sendxmpp. then created a script to fire off the alerts.