powered by Jive Software

1.0 Beta 7: ICQ encoding

I’'ve upgraded my Wildfire to 3.2.0 with Gateway plugin Beta 7. Now I have a problem with cyrillic encoding in ICQ messages:

If I set encoding to “windows-1251” in ICQ gateway options, other ICQ users receive my messages in wrong

encoding, but I receive correct messages from them.

If I set gateway encoding to “ISO-8859-1”, others can read my ICQ messages, but I get incorrectly encoded messages from them.

With Wildfire 3.1.1 and Gateway Beta 6b everything worked fine with gateway encoding “windows-1251”.

Hmm… In fact with Beta 6b (Wildfire 3.1.1) I also receive messages with incorrect encoding but outgoing messages are OK if I set the gateway to “ISO-8859-1”.

So I suppose it’'s a general encoding problem in Beta 7.

In addition - about encoding problems…

I have this problem too. Problem is existing if at other side is using client with UTF encoding (qip, genuine ICQ, Miranda with Unicode support).

Also, there is a problem with delivering offline messages from ICQ server - I don’'t see it. If I connect to ICQ with Miranda - all is OK.

About problems with contact list from ICQ server - I’‘ve found that if UIN is not in any group on server, it can’'t be added to roster in Jabber.

Also, there is a problem with delivering offline messages from ICQ server - I don’'t see it. If I connect to ICQ with Miranda - all is OK.

This is a known problem, see http://www.igniterealtime.org/issues/browse/GATE-113

Arg! It broke?? GATE-180 The joscar patches are supposed to be doing the trick . . . bah! I’'ll see what I can figure out or downgrade the patches.

I’'m having a similar problem with hebrew characters. If I set the encoding to windows-1255, messages are received correctly, but outgoing messages are sent incorrectly.

Using utf-8 does not work at all.

And yours also worked fine with 1.0 beta 6b?

Hi. I have the same problem with Gateway plugin 1.0 beta 8. Default encoding Windows-1251. In QIP i recieve normal russian message, but when i answer on it, I recieve unreadable characters. Debug log:

2007.03.01 14:08:02 icq: Sending packet: ???

2007.03.01 14:08:07 Received message packet: ???

2007.03.01 14:08:07 OSCAR bos snac response received: SnacResponseEvent: request=SnacRequest for SendImIcbm to me-icq (id=0, ackreq=true): IM: ???: listeners: , responses: null - SnacPacketEvent: snacProcessor=ClientSnacProcessor: lastreqid=17, requests: 17, paused=false, snacPacket=SnacPacket type 0x4/0xc: 19 bytes (id=17), snacCommand=MessageAck - FlapPacketEvent: flapProcessor=FlapProcessor: seqNum=SeqNum: min=0, max=65535, last(current)=18, flapCommand=SnacFlapCmd: packet=SnacPacket type 0x4/0xc: 19 bytes (id=17), flapPacket=FlapPacket (channel=2, seq=19185)

Message was edited by: DenShilkin

Hrm. Ok thanks! Clearly I’'ve missed -something.-!

Can y’'all give this a shot and tell me if it fixes the ICQ encoding issues?
gateway.jar (951978 Bytes)

I’‘m install new plugin. Now it’'s works

Looks fine for me too. No encoding problems so far.

Thanks a lot !

Thanks. Now it’'s workes well. Thank you.

BUT !! Offline messages are retrieved broken

Ohh… offline messages. sigh Ok here’‘s the thing, I’‘ve never managed to figure out how to get Offline messages to be encoded correctly. Unfortunately, unlike other messages, they have no encoding information tagged onto them what-so-ever. =( I’‘ll see if I can figure something out. Thanks y’'all!

If we propose that the Offline messages have Unicode encoding, we cat try to recode it to encoding setted in our settings?

jadestorm wrote:

Ohh… offline messages. sigh

I see you have closed GATE-180. Do you plan to open another “issue” for this ?

Oh yes actually, GATE-186 =)

Message was edited by: jadestorm

Priority:

Major

Wow! Thanks

Would you mind doing me a favor and trying this and teling me if it fixes the issue with offline message encoding?
gateway.jar (952377 Bytes)