powered by Jive Software

2.0.5 double opens on boot

Hi,

Installed 2.0.5 yesterday on a few stations. The client seems to “double open” now on Windows start up. There are two icons in the task tray, and closing one closes both. Is there a fix yet for this?

Hi Scott,

I have not been able to reproduce this. Spark should only allow one instance to run at anyone time, so it’'s a little strange that two instances would be running. Are you just using the 2.0.5.exe, or have you maybe installed using MSI?

Cheers,

Derek

I first installed the Java 6 Beta 2 runtime engine, then the spark2.0.5_online.exe version. I’‘ve checked the startup locations and can only find one instance that should be starting (in registery under user tree). It appears only one instance is running, it just shows up twice in the task bar. At this point I believe it’‘s a Java 6 issue, but will need to test more. Java 6 otherwize is increadibly fast so I’'d hate to have to loose it.

The problem appears to be intermittant. Some boots I get two, others I don’‘t. I guess it’'s from interference from another application.

I’'m also experiencing this problem. Running Spark 2.0.5 and Java 1.5.0_09. Also intermittant.

It’‘s nice once in a while to get an affirmation that I’'m not totally nuts

We are experiencing the double login oddity here as well. And, until Spark is closed and reopened with a single instance, the the douible instance seems to slow a PC down quite a bit. The slowness complaints are the support triggers. So far I can’'t see what makes it happen.

Still happening, is there any data I can provide?

I also have the double icons in the systray using Sparc version 2.0.7 on a Toshiba laptop using Windows XP Pro - Service Pack 2. As was stated before, closing one closes both, and a restart of the program brings up only one icon. While this may be just an inconvenience to me, I cannot have my users machines slowed down in a busy sales environment. Has anyone found an answer to this as yet?

Gerra

Has any sort of fix on this been reported? I have yet to be able to recreate the problem, however a client has informed us that there are some computers that are getting multiple intances of Spark on startup. Spark 2.0.7. Closing closes both, then re-open the program and only one opens.

Going to see if I cand gather more information about each computer.

I have looked in the Startup tab of msconfig, and see only one instance of Spark there. The problem seems to be on the first boot of the computer in the AM. I have not noticed any subsequent boots/reboots during the day to give more than one icon.

Message was edited by: Gerra

I’‘ve noticed that on my installation, I’'ve never selected anything about starting on Windows boot, but it still does. And I have no check marks in “Launch on Startup” and “Start in Systray”. I am going to turn those both on and restart at some point today, see if that causes anything.

Hello all,

After reading the comments by DefStatic yesterday afternoon, I double checked my settings. I did have “Start in Systray”, “Launch on Startup”, and “Auto Login” checked. I turned off “Auto Login”, and the client prompted for my password when I rebooted. I turned that back on, and turned “Launch on Startup” off. Both yesterday when I was playing with it, and this morning on first boot (when I would normally see two icons), I only see one icon in the systray. I believe DefStatic may have hit upon the solution.

I do find it strange, though, that they would program the client to “Launch on Startup”, and them give you the option to “Launch on Startup” all over again. Normally if a program does “Launch on Startup”, and you don’t want it to, you can’t find the place to turn it off. This seems like the same situation, except that Spark gives you the opportunity to turn on “Launch TWICE on Startup”.

Hi Gerra,

one should take a look at the registry, maybe the previous Spark version did install a start-on-boot key which is not compatible with the start-on-boot key of the current version. This would explain a lot.

LG

I will look in the registry, but this is a new install of version 2.0.7. I have had no previous install of any previous version. The only other Instant Messaging program I have ever used prior to this install of Spark version 2.0.7 was a trial of the Jabber client.

Also, the double icons were back in the systray this morning on boot-up. The problem is still with me.

Thanks for the suggestion.

Message was edited by: Gerra

I have looked into the registry, and I have seen the truth.

What I did not see, however, was any entry that would make me think that Spark is trying to start more than once. (This from a person with an extremely limited knowledge of the registry.) Actually, there were approximately a dozen entries mentioning Spark, including some that related to un-installing, and references to the Internet access and downloading of the program to begin with.

If there is any specific reference that I should be looking for, that could be helpful.

Thanks,

Gerra

I do not see where there could be more than one entry in the registry. However, could you guys open up the registry on the computer this is happening on and navigate to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run and see how many entries of Spark there are. This will help me debug the issue.

Thanks,

Derek

In the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run folder there is only one entry for Spark. That would be:

Name: Spark

Type: REG_SZ

Data: C:\Program Files\Spark\Spark.exe

The other entries are in:

HKEY_CURRENT_USER\Software\ej-technologies\exe4j\jvms\c:/progra~1/spark/jre/bin/ java.exe

HKEY_CURRENT_USER\Software\ej-technologies\exe4j\pids - 4 entries

HKEY_CURRENT_USER\Software\ej-technologies\install4j\installations - 2 entries

HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Internet

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Applets\Regedit - 1 entry

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\MenuOrder\S tartMenu2\Programs\Spark - Folder

HKEY_CURRENT_USER\Software\Microsoft\Windows\ShellNoRoam\MUICache - 2 entries

HKEY_CURRENT_USER\Software\NVIDIA Corporation\Global\nView\WindowManagement\spark - Folder

HKEY_CURRENT_USER\Software\NVIDIA Corporation\Global\nView\WindowManagement\spark_2_0_7 - Folder

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\windows\CurrentVersion\App Management\ARPCache\Spark 2.0.7 - Folder

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\windows\CurrentVersion\Uninstall\Spark 2.0.7 - 2 entries

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\ej-technologies\e xe4j\jvms\c:/progra~1/spark/jre/bin - Folder

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\ej-technologies\e xe4j\ - 4 entries

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\Microsoft\Office\ 11.0\Common\Internet - 1 entry (Temporary Internet Files)

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\Microsoft\Windows \CurrentVersion\Applets\Regedit - 1 entry

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\Microsoft\Windows \CurrentVersion\Explorer\MenuOrder\StartMenu2\Programs\Spark - Folder

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\Microsoft\Windows \CurrentVersion\Run - 1 entry

HKEY-USERS\s-1-5-21-594873674-2015652978-6498272-2506\Software\Microsoft\Windows \ShellNoRoam\MUICache - 2 entries

After this I stopped searching. I am pleased that you are looking into this issue, and look forward to any suggestions that you might have.

Thanks

Gerra

Hello all,

Yesterday, I upgraded to Spark version 2.0.8 (from 2.0.7). While doing that I also unchecked the “Start in Systray” setting. Lo and behold, the program started in the systray anyway. Kind of redundant (and repetitive), isn’'t it?

The result of my changes? This morning, I had two icons in the systray. Exiting from one of them closed both icons, and restarting the client brings back only one icon to the systray.

Conclusion: No answer yet!

ddman - have you come up with anything after looking at the list of registry entries yet?

By the way, after 10 installs, the only computer to have reported this problem is my own.

Gerra

Message was edited by: Gerra

Message was edited by: Gerra

I haven’‘t encountered this issue yet however when I installed spark I noticed that even with the start up option unselected Spark was opening every time I started. I ended up having to use “msconfig” and de-selecting the spark application from the list. Another thing you can look for is to see that the application is now in the startup folder. Most likely won’‘t be the problem but couldn’'t hurt to check