After plugin update it disabled and unavailable

Hi all,

I have updated the plugins in my Wildfire 3.1.0 Beta 3, but after update it disable all updated plugins and remove “install” button.

2006.10.10 12:35:57 org.jivesoftware.wildfire.container.PluginManager.loadPlugin( 459) Error loading plugin

java.lang.ClassNotFoundException: org.jivesoftware.wildfire.plugin.UserServicePlugin


at Method)


at java.lang.ClassLoader.loadClass(

at java.lang.ClassLoader.loadClass(

at org.jivesoftware.wildfire.container.PluginClassLoader.loadClass(PluginClassLoad

at org.jivesoftware.wildfire.container.PluginManager.loadPlugin( :339)

at org.jivesoftware.wildfire.container.PluginManager.access$200( :47)

at org.jivesoftware.wildfire.container.PluginManager$

at java.util.concurrent.Executors$

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(

at java.util.concurrent.FutureTask.runAndReset(

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(

at java.util.concurrent.ScheduledThreadPoolExecutor$

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask( 650)

at java.util.concurrent.ThreadPoolExecutor$


How to fix this?


Best Regards,

Fernando Ribeiro

Message was edited by: musb


please try Wildfire 3.1.0 which was released yesterday.


Exists any automatic update system?



I’'m not aware of one but how to update Wildfire manually was discussed very often.


No automatic updates for Wildfire yet. After you install the final version of 3.1.0, your updated plugins should work fine though.



I did the same thing. I updated my plugins on my Wildfire 3.1.0-beta2 server and they were dead. So I shutdown and upgraded to 3.1.0 however after restarting I’‘m in the same state. The plugins list appears empty and says ‘‘no plugins installed’’ and the ‘‘available plugins’’ page doesn’'t have the + to install next to the plugins I think I should have installed.

How does one re-install/repair a plugin?

i get the same problem when i upgraded it from 3.0.1 to 3.1.0. in addition, the vcard function from ldap become empty.

I´ve got the same problem with plugins. The plus sign isn´t available when they are installed, but they don+t appear on installed also.

I´ve moved from 2.4.4 to 3.1.0.

Don´t know if it´s explicit, but this plugins aren´t working…

I was just notified by a user that the vCard info is no longer working. Any help here?


are you using LDAP, DB auth and user provider or the normal database to store the users and vCards? For LDAP there is a separate thread somewhere (=> run the setup again), the DB user provider does no longer work (JM-848).


Everything worked on 3.0.x. vCards are still set up like it says in the docs for LDAP provided vCards. I did not change my wildfire.xml. Updated to 3.1.0 and now it doesn’'t work.

“+we had to “break” a few things in existing installations. Specifically, the vCard mapping syntax+”

I too lost plugins and the ability to install them again. This happened after upgrading the plugins via the upgrade button. I tried upgrading the server but that didn’‘t make a difference. I’'ve been checking this thread and have yet to see any progress. Anyone know if the developers are aware of this issue?

the vcard work again when i change the format of vcard settings. for example, change to .

but the plugins didn’'t work yet.

as to the plugins problem, the log from error.log is:

2006.10.20 15:09:18 [org.jivesoftware.wildfire.update.PluginDownloadManager.updatePluginsList(Plugi nDownloadMan]

org.dom4j.DocumentException: Error on line 4 of document : An invalid XML character (Unicode: 0x1) was found i

n the value of attribute “name” and element is “plugin”. Nested exception: An invalid XML character (Unicode: 0

x1) was found in the value of attribute “name” and element is “plugin”.

need your help!


Message was edited by: cityham

Hey guys,

Can you tell us which plugins have you downloaded before starting to have this problem?


– Gato

I had only User Import Export.

After the error I removed the plugins, deleted jars and directorys, donwloaded again User Import Export, Broadcast and Presence Service, stopped the server, putted the news plugins jars in the directory…But all remained the same.


I was running Wildfire 3.1.0 Beta 3 on Fedora Core 5. I had all the plugins installed except for Asterisk-IM, Presence Service, User Service. I did the plugin updates via the update button that was displayed. After that they no longer showed up as installed. Also the green install button was no longer available to install them. I then upgraded to 3.1.0 figuring that would fix the problem. It didn’‘t have any affect. The 3 plugins that I didn’‘t install are still able to be installed via the green install button. I’‘m assuming upgrading the plugins, which I hear don’'t work under the beta, before upgrading the server is the cause. Is there some way to re-add the plugins so they can be installed again?

I did notice that I still have the broadcast feature available. Does that mean that the plugins are installed just not showing up?

Message was edited by: tmurray

the plugins that i installed before starting to have this problem are broadcast, contentFilter, search and userImportExport.

Re: after plugin update it disabled and unavailable

Posted: Oct 20, 2006 11:08 AM

Hey guys,

Can you tell us which plugins have you downloaded before starting to have this problem?


– Gato