powered by Jive Software

Android Client on private server

I have openfire 4.5.1 and have installed the Open meetings plugin. I have created a Lets Encrypt SSL cert for my external IP and linked the complete chain to my install under the SSL/Certificates section.

I have pinholed the ports, and put in te require DNS settings for local loopback etc as required.

From externally and internally, I can access my instance via a web browser without any issues.
From externally or internally I cannot access it via the Jitsi meet Android App to my server. Works fine to the meet.jit.si server.

I am using the url https:\mydomain:7433\ofmeet\meetingname

Is there anything I am missing??? or is the app not supported for private servers??

Thanks

Change the folder from /ofmeet to /
The app only works with a root folder

Thanks!! Should have tried that first.

Dele, I’ve been trying the same thing, would it be

https:\mydomain:7433\

That I should put in the server url in the jitsi app?

https://your_server:7443/

Yeahp, I meant in that format, funny thing, I still get the disconnected message, can’t even connect to create a room. Gonna recheck my configs to see if there’s something missing here

@GeekZilla. Originally when I changed it to the root / it worked for me, but then it stopped working. I have been testing internally and externally, and been having sporatic random results. When I manage to actually get it to work, it says the app is the only person in the meeting, and cant see anyone else, and the user doesnt show up in the session in openfire. Not even sure how it is even accomplishing that

1 Like

It’s quite strange, the jitsi app works fine with any other jitsi server, but with ofmeet it’s kinda bugged.

1 Like

I have not used it in a while as I use my own android build which works fine. I have just downloaded it and tested with my own openfire server and latest ofmeet plugins and it works ok for me.

You may have to try much harder than that before you can dismiss it as being bugged

You cannot compare your server behind a NAT with a public server like meet.jit.si

Hey there Dele, well unlike [texynz] my server is fully exposed to the web, all ports open (I even disabled the firewall for a while to check it ) .

I mean, it’s not that hard, we just put the address on the jitsi meet app and it should work, but it’s still a no go.

Seen that I need to take a deep dive on the logs and see if I can get a clue about what’s happening, in the meantime I will also spin up a second server with just jitsi and see if it works.

I will keep you posted if there’s any updates on this.

@GeekZilla I have my server with NAT, but also tried in DMZ with erractic results, so missing something still. I also have the proper SSL certs, so not just self signed, which wont work with private servers.

I have just downloaded it and tested with my own openfire server and latest ofmeet plugins and it works ok for me.

@sunnywilson09 can you share you confirguration?? I have tried on Pade (built on 0.98) and also the latest 0.95 without much luck

Hey, I finally got it to work, I had to go to server properties and first change the ofmeet.webapp.contextpath from /ofmeet to just / , the jitsi app then started to work but the web client (the jitsi web) didnt.

Then I reverted the ofmeet.webapp.contextpath to /ofmeet , restarted the server and both are working!

I will install a clean server as soon as I can to better understand the inners workings of the whole thing. since I got OF running on a production server I can’t really mess around, especially because right now it’s our main communication channel.

Still looks as some bug/tilt on the jitsi implementation, but since it’s working I dont really mind.

1 Like

@GeekZilla, was this with the 4.5.1 and 0.95 or the pade plugin?? Sounds odd that this should work. So the URL to access the meeting as per below??

Web: https://myserver:7433/ofmeet/mymeeting
Android: https://myserver:7433/mymeeting

I will give this work around a try also.

I have done some more testing, it I suspect it is something to do with the andriod app on my phone (Andriod 9 on a Nokia 8). On the phone, I can get in via the web/chrome no issues, but the app just keeps on "trying to reconnect. I managed to get it to connect once and it worked perfect both on 4G and Wifi. As a test, I enabled and disabled the airplane mode (i.e disconnected the network connections) and tried again, and it would not connect again. Investigating further. @Dele_Olajide the app you used/wrote what have you set the connection time out at?? Thanks

I dont remember, but you check here - https://github.com/igniterealtime/pademi/tree/master/Jitsi-Meet

Further testing resulted in some interesting results. Constant repeated attempts at connecting to the private server via the android app, either connected internally or externally was unsucessful. Tried clearing the app cache and no change. But immediatly after connection to a meeting hosted on meet.jit.si I was able to connect to my private server, internally and externally. Will repeat these tests again to confirm my findings, and also on another phone to see if a phone or carrier issue.

please share your configuration ?