Cannot login to admin console

On the 22nd, I recalled going into edit LDAP changes, and noticed that my baseDN and AdminDN was wiped out after clicking on the edit button. I cancelled the procedure and now I can’t log into the admin console.

Is there a default admin password on the thing? I never added one, I only added the AD admins when prompted.

Any assistance is greatly appreciated.

What version of openfire? What type of database?

3.6, embedded

Your only real choice then since it is bound to LDAP is to force the Openfire confuration script to rerun. This is done by:

  1. Stop Openfire
  2. edit the openfire.xml file setup tag to read false
  3. Start Openfire
  4. goto admin website and step through the config again

your data will be preserved as long as you keep the server name the same as before.

Awesome, thanks for the help! Any ideas why the BaseDN and Admin DN get wiped out when you do an edit, under Profile settings?

Hey Todd, not sure if this is a bug in Openfire 3.6 or not, but anytime I make a config change via the admin console, I lose my config settings? I added a few plugins and restarted the Openfire services and couldn’t log in again. I fixed it using the steps you provided previously, but find it very frustrating. I did not have this issue in the dev environment. It only seems to occur with the integrated LDAP settings configured. Do you know if this gets fixed on 3.6a?


I have not seen that error on any version of openfire from 3.2.x to current 3.6.x. It sounds to me like you have a configuration issue somewhere.

As I mentioned, it only seems to happen with the LDAP integration setting. I set Openfire up in a dev environment prior to putting it in production WITHOUT LDAP integration and it worked fine. In fact, when I added the Fastpath plugins, I even got a demo group. But not on the prod server.

there will be no default group in fastpath with LDAP config. I have a doc for that. Can you provide specifics of the OS of openfire and what LDAP server.

According to the Fastpath plug-in read me file, it states “When you use Fastpath for the first time. you’ll use the demo workgroup to begin setting up your system and to see how Fastpath components work together…” What doc are you referring too?

When i did this in the dev environment, i did in fact get a demo group.

The specifics of my environment are:

Windows Server 2003, sp2

Openfire 3.6
LDAP = Active Directory 2003

See attachment.

That document is out dated and omits information with regards to LDAP. I would not reference it. I have done some minore updates to the doc and published 2 different versions to address LDAP. I also have docs specific to AD integration. They need updated for Openfire 3.6.x but are still very good guides. I may be so bold as to suggest switching to MySQL for windows on your server that houses Openfire. It has a nice gui and is easy to manage and backup.

Can you please provide me with the docs you speak of, also what benefits would MySql give me that the embedded wouldn’t?

I look forward to your reply.

Todd’s answer is the one I always use/give.

I too have LDAP integration and EVERY time I click to edit my LDAP settings with the admin console it clears those two fields.

I have gotten in the habit of doing a copy of the admin DN prior to clicking on edit, that way I can at least paste the data and the base dn is easy to retype.


My docs are here:

As for the benefits of mysql over the embedded database:

  • Windows GUI management tools
  • Scheduled backups of database
  • Simplified disaster recovery
  • Supports larger data sets
  • Can remove old chat logs
  • etc

So it sounds like a bug, will this be fixed in Openfire 3.6.a?

Not only do I experience this issue when modifying the LDAP settings, but when adding plugins as well. The good thing is, most of the settings are preserved in the embedded db, but still.

How hard is it to move to a MYSQL db from embedded? Do I need to reinstall?

I cannot anser for the issue when adding plugins bcause that never happens for me, but changing LDAP settings will still mess with the config in the latest build. As for the transfering to mysql there is no easy path of migration from the embedded DB. This has been discussed at length several times before. You would not need to reinstall as much as run the config again by modifying the setup tag in the openfire.xml.

So to make sure I’m clear on switching to MYSQL, I can change the Openfire.xml flag to false, then step through the setup process again and choose to use an external database?

Also, what is your experience with adding an SSL cert to both Webchat and IM?

I have not used any certs other than the self created certs of the server. And yes you should be able to change to an external DB when stepping through the config.

Do you equally recommend MS SQL with Openfire, or is MYSQL the db of choice?