Cant install fastpath webclient on openfire

I just downloaded fastpath open source and the webclient, fastpath seems to be installed correctly and I configured everything but when trying to open the webclient thru the tool option on openfire admin, I get a fastpath window saying to select on of the workgroups that chat to or something but there is no list to select from.

Also on openfire I get an error saying it cant resolv hostname or something each time webclient tries to connect, eventhough the test connection says its OK.

Anybody having this issues?

the warn error I get is this:

008.07.06 16:49:37

Closing session due to incorrect hostname in stream header. Host: Connection: socket:


http://addr=/,port=55907,localport=5269] session: null

hostname has been XXXX for privacy

I built the code also, however, its possible to actually download the plugin for openfire directly, then goto server:9090/webchat , wonder if that gives you any mileage?

Well what I did is install the plugins from inside openfire admin console / plugins… is there any other way to install the webclient plugin?

You can get the source, build and deploy under tomcat / JBoss etc, this gives you the ‘latest’ but I didnt get success that way. f-fastpath-is-now-available

How did you configure your settings for the webchat server? This is a sample config as found in the chat-settings.xml file for the plugin:







Note the port is the standard XMPP port used by the server.

thats exactly what I have but still I cant get it to work

BTW Im not using any java server, Im trying to run it on a standard openfire installation under apache/php/mysql…

Ok now for the obvious questions. did you reboot the server? did you check permissions on the directory?

Are you using LDAP or self registered users? If LDAP did you completely configure the queues for the webchat workgroup? Try to resave the settings for the queue if you did.

webchat is installed as a plugin… all other plugins are working without problems and all permissions look ok

the agents are registered as users on openfire… for the webchat client, anon users are permitted…

So the demo workgroup and queues were automatically created for you on install of the plugin?

Yes, the fastpath plugin seems to be working great, the spark agent also signs into the workgroup.

The problems comes with the webclient… inside openfire, when you go into the fastpath tab, you see a TOOLS option, when you click on that it opens up a page that should show up the webclient for testing, there it says please select a workgroup to contact but the list is empty eventhough there are workgroups defined and agents logged into them… also on openfire’s warn log I get this error:

something about hostname bad on heather or something.

for webchat to work your XMPP domain needs to match your Openfire certificates, which need to match the DNS name of the server. Do all those variables match up.

Also try accessing it from its real domain name not localhost or

Im not using SSL or TLS, does that matter?

Whether oyu use it or not all those variables must match. and that name must be what you entered into the webchat config.

you were right! the domain config on the wevchat config file was wrong… I need to make some mods about that but once I entered the same thing on everything it worked!

this seems to be a crossdomain limit on flash…

thank you for all the help!!!

I think I am having this same issue. I installed the Fastpath Service and Fastpath Webchat plugins, went to http://:9090/webchat to do the setup, then restarted the server. We created workgroups, and had users sign in. The workgroups showed in the admin console as open. However, Trying to go to the Tools tab with the Fastpath section gave me a page that had instructions to select a workgroup, but nothing else besides that.

I tried to do what you suggested here, but cannot find the config file. Could you help me? We are using the latest versions of OpenFire and Spark.

If you installed from rpm, the file that you need to modify is:


make sure that


where XXXXX has the same name as what your openfire is named… this you can get from the main screen when you first log into openfire.

Hope this helps.