powered by Jive Software

Certificate hostname verification failed Spark 2.8.1

I have the following error when you log on to spark

oct 03, 2016 10:42:42 AM org.jivesoftware.spark.util.log.Log warning

ADVERTENCIA: Exception in Login:

org.jivesoftware.smack.SmackException: java.security.cert.CertificateException: Hostname verification of certificate failed. Certificate does not authenticate 192.168.2.250

at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPC onnection.java:1029)

at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.access$300(XMPPTCPCon nection.java:956)

at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader$1.run(XMPPTCPConnecti on.java:971)

at java.lang.Thread.run(Unknown Source)

Caused by: java.security.cert.CertificateException: Hostname verification of certificate failed. Certificate does not authenticate 192.168.2.250

at org.jivesoftware.smack.tcp.XMPPTCPConnection.proceedTLSReceived(XMPPTCPConnecti on.java:775)

at org.jivesoftware.smack.tcp.XMPPTCPConnection.access$1000(XMPPTCPConnection.java :140)

at org.jivesoftware.smack.tcp.XMPPTCPConnection$PacketReader.parsePackets(XMPPTCPC onnection.java:1022)

… 3 more

Captura1.JPGCaptura2.JPG

The option that provides the 2.8.1 version works to correct this problem.

Disable certificate hostname verification (not recommended)" in the Advanced settings of the Login screen. If you can’t fix your setup or want a temporary workaround, you can use it.

But I would like to know the steps to correct the issue of certificates.

I hope I can help with this problem.

General explanation of a problem Login issues since Spark 2.8.0

In your case you would have to change the name of your server (it will not work with IP instead of a name). To change the name you will have to rerun the setup and change it during the setup (you can skip admin password step). Keep in mind, this may cause issues, so it is mostly recommended for a server in the testing phase. Also do not forget to delete old certificates after rerunning the setup.

Hi! I had the same question, so I work a lot and I was lucky
!

The openfire_4.0.2_all.deb works only with version “1.8.0_111” Spark 2.7 and java.

only that!

thank you.

Not true. Spark 2.8 works just fine if you are not a lazy admin…

Yes Wonderful administrator and nothing lazy sir!! Spark 2.8 displays the error described above for Openfire is in version 4.0.2, then you have to be used the Spark 2.7. As seen David Rodriguez is using openfire 4.0.3 and Java 1.8, and the spark 2.8.1. I believe you have to put the java 9 or regress the spark.

Spark 2.8.0/2.8.1 and 2.8.2 (which will be released soon) works fine with Openfire 4.0.2/4.0.3 and the future 4.0.3/4.1.0 even. If you get the error above you either can’t use a proper domain or went a lazy way of using IP instead. That’s the same if we were using IP to browse internet. Imagine having to put 216.58.214.206 instead of google.com to your browser or having email address with @206.190.36.45 instead of @yahoo.com. Same with xmpp. A server has to have a proper DOMAIN, then you won’t get that error. If you don’t want to do that, then enable “Disable hostname certificate verification” in Advanced settings and Spark will connect.

Also, all of Spark and Openfire versions above are using Java 8. Actually Openfire is not working correctly with Java 9 as far as i know. So, no, you are fine with Java 8.

I’m actually having the same issue. I have my ip set to a domain which I do anyway but I still get this error. My vps has the latest java version what ever is in 2017… I don’t mind disabling the thing in advanced of spark, however I’m running spark 3 and I get this still.

error is Certificate hostname verification failed

This is already explained a few times in the link above and in this same thread. I don’t know what to say more. If you don’t understand how to deal with this, then maybe hire a network administrator (knowing DNS stuff) or just keep using Spark 2.7.7.

Well, since spark actually hinders its use by throwing up a lot of “system dialogues” that voiceover can’t deal with I took it off of my system. So it’s back to finding something else to use. Thanks.

A post was split to a new topic: How can i connect KAIDAN xmpp to openfire server?