powered by Jive Software

Conference group - file transfer


#1

hi all,

i have set up a conference group and all my users can join in the same conference group but i dont see the options for file transfers and i have tried dragging dropping files but it doesnt work

any idea on how i can get this to work, or is this just not an option in conference groups like it is in normal chat

thanks,
rob


#2

Yes, group chat doesn’t support regular file transfer. HTTP File Upload is designed to help with that. Openfire has plugin for it. Clients have to have support for it also (say Gajim, Conversations on Android, Spark only supports it in not released yet 2.9.0 version). It then allows user to select a file and it is presented as an URL in the chat (file is stored on the server).


#3

Do you mean install this plugin on the openfire server, -

https://www.igniterealtime.org/projects/openfire/plugins/httpfileupload/readme.html


#4

Yes


#6

Ok so i see the plugin in the plugins folder, restart the server

Now is it just a case of dragging dropping a file in the group chat window?


#7

It depends on the client, how it is implemented. Say in Spark 2.9.0 there is a button to select a file. Same with Conversations client.


#8

Ive got spark 2.8.3, where can i get 2.9.0

EDIT-when i start a normal chat with someone else i see the file transfer and capture icons but when i start a conversation/group chat i dont see non of the file transfer or capture icons, nor do i see a menu bar


#9

Got it, nightly builds

https://www.igniterealtime.org/downloads/nightly_spark.jsp


#10

Yep, the http file upload button is using the clip icon and is near the emoticon picker button.


#11

nice one wroot!!!

its awesome, when i send an attachment anyone in the group can click on the link and it opens the actual file in the link ie they can view it, dont even need to download it

what about if they need to download the file and not view it?


#12

I don’t know. Only tried to upload images this way. You should be aware that these files will be stored on the server and they will be left on the server and can take space after a while.


#13

Yeah i read about that… But if you reboot server they get flushed, do you know where there stored as i can do a bash script to remove them after 14 days


#14

I don’t know where they are stored on Linux systems. Look around in tmp folders. Readme is not correct. In my experience on Windows files are not deleted after server reboot and stay in temp folder.


#15

did a find command and i know where it keeps the data -

/tmp/xmppfileupload5298669046648866664/

i did a rm -rf /tmp/xmppfileupload5298669046648866664/*

and i click on the link and it still is there?


#16

The name looks the same as on Windows. Have you rebooted Openfire after you have deleted the file? Openfire might still have it cached (or your browser).


#17

great rebooted the server now everytime i attach an attachment, my spark hangs and doesnt upload the picture ie make it a http link

EDIT, scrap that i was accessing over VPN but when i access my pc locally i can now attach files again


#18

smashed it

so i need to do -

rm -rf /tmp/xmppfileupload*/*

as it creates for each reboot another “xmppfileupload” directory


#19

A post was split to a new topic: Not able to paste screenshots in conference