Connecting problem

hello , first sorry for my english , im czech

im little bit lame , but tried this for our small (100 member) community site . my problem is connecting with clients (like miranda , gajim , gaim , sparc …) , i cant see them in admin console , but client (without proxy , tls , ssl) register new account ant nothing more …

here is my wildfire.xml[/url]//[/url] its clean . i tried in admn console only ssl , tls , without both and still nothing .

i think , i didnt set something (or bad setting) , but dont know where is it

Message was edited by: psycho

Message was edited by: psycho


this file contains “77,7 Bot” at the end, I assume that or wildfire.xml does end with . Did you set up an xmpp.domain / server name (like and a DNS entry which resolves it (like “nslookup” ==> Address: 208.245…) ?


xmpp.domain is jabber.ernet

but i dont know where to dns

now i found in war.log this :

A connection to the server could not be made when attempting connection to jabber.ernet

and if i write to browser : http://jabber.ernet:9090 its ok …:frowning:


When you connect from your IM client, was it from the same machine that you did http://jabber.ernet:9090?. If it’'s the same, then it might be the firewall at jabber.ernet. What are you getting if you telnet jabber.ernet ?

hi , hmm this says telnet : Trying…

telnet: Unable to connect to remote host: Connection refused

admin said : all ports , that you want are open , and on this server is for example phpbb forum , or teamspeak

Oops, sorry. What I meant was telnet jabber.ernet 5222. Can you try once again? What are you getting?


Connected to jabber.ernet.

Escape character is ‘’^]’’.

heh , im just copyman

Copyman? That’'s ok Lets take it one at time because I have problem understanding.

Then you should be able to connect. What did you enter in the Username: and Server: box on your IM client?

username: something , psycho …

server : jabber.ernet

i tried create account in im , then create it in admin console …

now gaim said read error . only psi can connect/create acc , but nothing else , i cant post message , join chat …

Can you connect if you change the Jabber config in Gaim to enable “Force OLD SSL” option?

no , i cant

here is system preferences

locale.timeZone GMT

passwordKey hidden

register.inband true

register.password hidden

update.lastCheck 1157293968789

update.notify-admins true

update.proxy.port -1

update.service-enabled true false

xmpp.audit.days -1

xmpp.audit.filesize 10 false

xmpp.audit.logdir /opt/wildfire/logs

xmpp.audit.logtimeout 120000

xmpp.audit.message false

xmpp.audit.presence false

xmpp.audit.totalsize 1000

xmpp.auth.anonymous true

xmpp.client.compression.policy disabled

xmpp.client.tls.policy optional

xmpp.component.permission blacklist

xmpp.domain jabber.ernet

xmpp.muc.history.type number

xmpp.offline.quota 0

xmpp.offline.type drop

xmpp.privateStorageEnabled true

xmpp.proxy.enabled true

xmpp.proxy.port 7777

xmpp.server.compression.policy disabled

xmpp.server.dialback.enabled true

xmpp.server.permission blacklist

xmpp.server.tls.enabled true

xmpp.session.conflict-limit 0 true

sorry for formating , i thing there is something wrong

Sorry that I can’'t help you still.

I couldn’'t spot any error in system property.

Perhap if you enable Gaim’'s Debug Window, you could see at which point that it fails. Can you post the packet exchanged between Gaim and Wildfire?

yes , but i dont know where is it

Edit file ~/.gaim/prefs.xml, find:


Set value=’‘1’’, save and restart your Gaim.


here is it :

accounts: Writing accounts to disk.

account: Connecting to account 0x820d958. gc = 0x84a6210

connection: Connecting. gc = 0x84a6210

connection: Calling serv_login

server: gaim 1.5.1cvs logging in hovad@jabber.ernet/Gaim using Jabber

dns: Created new DNS child 15041, there are now 1 children.

dns: Host ‘‘jabber.ernet’’ resolved

proxy: Connecting to jabber.ernet:5222 with no proxy

proxy: Connect would have blocked.

proxy: Connected.

jabber: Sending:

blist: Destroying

connection: Destroying connection 0x84a6210

accounts: Writing accounts to disk.

Looks like it’'s the problem at the server side.

Can you post the content of file logs/error.log specific to that failed connection? The file can be found in the directory you installed Wildfire. Normally if you’‘re installing on unix, it’'s /opt/wildfire/logs/error.log

there are no errors , but after start , theres something :

2006.09.03 16:37:36 org.jivesoftware.wildfire.spi.ConnectionManagerImpl.startClientListeners(Connect cant set server socket / or if i activate ssl , then : cant set ssl socket

followed by : Address already in use

at Method)

at Source)

at Source)


at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)

at java.lang.reflect.Constructor.newInstance(Unknown Source)

at java.lang.Class.newInstance0(Unknown Source)

at java.lang.Class.newInstance(Unknown Source)

at org.jivesoftware.wildfire.starter.ServerStarter.start(

at org.jivesoftware.wildfire.starter.ServerStarter.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

at java.lang.reflect.Method.invoke(Unknown Source)

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)

Aah! I think we’'re getting into something…

Are you running Wildfire and ConnectionManager (CM) on the same server? Cause, if you do, then Wildfire has likely bound to port 5222 and/or 5223. When you run CM on the same server it tries to bind to that same port, and surely it will fail.

CM is meant to run on separate server from Wildfire, but if you want to run on the same server, here’'s one of the ways to make it work:

  1. Kill all Wildfire and CM

  2. Edit Wildfire’'s config file (wildfire.xml) and insert these lines:

  3. Start Wildfire

  4. Start CM

That will make Wildfire to bind on loopback interface, and let CM bind to

Hope that solves your problem.