powered by Jive Software

Enabling Message Carbons in Cluster

Hello, guys!

Another problem that I met when setting up cluster.

Property of client session ‘messageCarbonsEnabled’ not synced among nodes of cluster.

Please, check and approve my short fix. I already use it and for me it work.

See in attachment.
messageCarbons_cluster_support_03.diff.zip (1820 Bytes)
messageCarbons_cluster_support_02.diff.zip (1158 Bytes)
messageCarbons_cluster_support_01.diff.zip (1251 Bytes)

1 Like

Some quick notes from a first glance:

You are missing @Override annotations.

You are putting the enabled status into the cache, only if (ClusterManager.isClusteringStarted()).

Is that correct?

Are there RemoteClientSession, even when not using clustering? Because they expect to find the values in the cache.

Oh, I missed.

Little bit later I will fix it and check.

Update:

You are putting the enabled status into the cache, only if (ClusterManager.isClusteringStarted()).

Is that correct?

Yes.

Are there RemoteClientSession, even when not using clustering?

No, like I see RemoteClientSession can created only by RemoteSessionLocator that in its turn will be setted in case if cluster have at least two nodes.

Thanks

I am facing this issue as well.

Is this planned to be merged anytime?

Hello,
i have a simular issue with hazelcast and message carbon.

Thread

Did you manage to synch all clients over all clustered servers?